[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Scribus scripts



On Mon, 2007-10-01 at 12:15 -0700, Craig White wrote:
> On Fri, 2007-09-28 at 22:47 -0400, Todd Zullinger wrote:
> > Craig White wrote:
> > > Apparently Scribus uses python for scripting language but the scripts
> > > aren't installed on x86_64 but only on i386
> > [...]
> > > am I missing something here?
> > 
> > Nope.  This appears to be a bug in the 64 bit builds.  It affects
> > ppc64 as well as x86_64.  I reported it to bugzilla here:
> > 
> > https://bugzilla.redhat.com/312091
> > 
> > It seems like a simple fix, but I don't have an x86_64 boxes to test
> > with.  As linked in the bug, the fix is reported to be to add
> > --with-extra-libs=%{_libdir} to the %configure call in the spec file.
> > (I think that the --with-python-dir=... option can be removed then,
> > but I haven't tested that.)
> > 
> > If you can build an test with the attached changes to the scribus spec
> > file, add a comment to the bug report if it helps.
> > 
> > (Disclaimer:  I know next to nothing about scribus, I was just curious
> > about the build failure. :)
> ----
> OK - haven't added any comments to bugzilla but I will but wanted to
> report my lack of success thus far with building from adjusted spec
> file.
> 
> First of all, it appears that both the i386 and x86_64 versions of
> python devel & libs are installed so after a few abortive installs, I
> removed the i386 devel and libs packages.
> 
> still though, according my build logs (both commenting out
> with-pythondir= line and leaving it in)...
> 
> Configuration Summary:
> 
> Libraries:
>    Freetype2 installed:     Yes
>    Fontconfig found:        Yes
>    CUPS installed:          Yes
>    LittleCMS installed:     Yes
>    libtiff installed:       Yes
>    Libxml2 installed:       Yes
>    Python installed:        No (or too old - 2.3 required)
> Configuration options:
>    Debugging enabled:       No
>    cairo enabled:           No (If you don't know you need this, ignore
> it)
> Other details:
>    GhostScript 8.15 was found at /usr/bin/gs
> 
> 
> Good - your configure finished. Start make now
> 
> + --with-extra-libs=/usr/lib64
> /var/tmp/rpm-tmp.12154: line 52: --with-extra-libs=/usr/lib64: No such
> file or directory
> error: Bad exit status from /var/tmp/rpm-tmp.12154 (%build)
> 
> 
> RPM build errors:
>     Bad exit status from /var/tmp/rpm-tmp.12154 (%build)
> 
> which leads me to the obvious problem is that it is not finding what it
> expects for python. I have tried the following...
> 
> in the spec file...
>    --with-pythondir=%{_prefix}
>    --with-extra-libs=%{_libdir}
> or
>    --with-pythondir='/usr/lib64'
>    --with-extra-libs=%{_libdir}
> or
>   commenting out the pythondir altogether and
>    --with-extra-libs=%{_libdir}
> 
> still no change.
> 
> It does build ok if I remove the '--with-extra-libs=%{_libdir}' but of
> course, without the python scripts.
----
OK - I was wrong...this did work - I forgot the \ at the end of the
line. Therefore, this works...

%build
[ -n "$QTDIR" ] || . %{_sysconfdir}/profile.d/qt.sh
%configure  \
   --with-pythondir=%{_prefix} \
   --with-extra-libs=/usr/lib64
make %{?_smp_mflags}

but of course, this is for the x86_64 so some logic would have to be
integrated.

I'm going to test this out on ppc in a few minutes

Thanks (and I will report to bugzilla)

-- 
Craig White <craig tobyhouse com>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]