[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Unable to resume from suspend.



I found the quirks page to be a waste of time.

The out-of-the-box F7 never resumed from suspend on my Dell D820
latitude.  No matter what I tried, it did not resume, no matter what
video driver.

Then magically, with a kernel update, it did work!  All was fine for a while.

Then, just as magically, with a kernel update and or xorg update, the
resume quit bringing the video back.  The last kernel I remember
working was 2.6.22.1-41.fc7. It quit resuming from suspend about 3
kernels after that, possibly 2.6.22-4.65.  About the same time, there
were video driver updates, but somehow I doubt they are at the heart
of my trouble because I've tried xorg's nv and the commercial driver
from Nvidia and no success.  It is the same situation I was in

There are deep problems in the kernel that people are working on all
the time, and they have co-incidental effects on suspend/resume.  I
spend a lot of time in the fedora-development list and found many
experts, all of whom had good advice and reasons why suspend does or
does not work at any given moment.

Unless you are willing to spend a lot of time debugging, forget it.
FOllow the manufacturer's advice, which is DO NOT use suspend.
Suspend is dangerous becuase, if you move your computer about, it may
inadvertently turn itself on. Use it only when the machine is not in
the bag.  I swear, this is the manufacturer's advice, although many
people ignore it.

If you are willing to spend some time, here is a way to start.

When  you are on the laptop, make sure you are able to log onto it
from another system with a program like ssh.  Then suspend the laptop
and resume it.  Then try to log in again. If it does work, it proves
you have only the simple problem of waking up the video card. If that
is the problem, then maybe the advice in the quirks page will help
you.  Maybe not.

If you cannot log in again, it means your system may not have woken up
at all, and that is a worse problem that you should report in the
bugzilla.redhat.com.  They need to know details on your machine and
the kernel you are using at the moment.

And, yes, I'm top posting because I like it.  Or gmail likes it.

pj

On 10/1/07, Michael <4magnell ruraltel net> wrote:
> On Mon, 2007-10-01 at 09:42 -0400, Matthew Saltzman wrote:
> > On Sun, 2007-09-30 at 23:47 -0500, Michael wrote:
> > > I was hoping this would be as easy as the touchpad fix. After some
> > > searching I'm confused instead of ignorant, no going back now. The
> > > suggestions for fixing this vary pretty good from adding kernel lines to
> > > using only free drivers or even installing programs. Anyone have a good
> > > understanding about what is causing the problem on my fedora 7 with
> > > model laptop-hp pavilion ze4427wm?
> >
> > >From what I can gather, the place to start is here:
> >
> > http://people.freedesktop.org/~hughsient/quirk/
> >
> > Good luck!
>
> Thanks you, I will look at that soon.
>
> --
> fedora-list mailing list
> fedora-list redhat com
> To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
>


-- 
Paul E. Johnson
Professor, Political Science
1541 Lilac Lane, Room 504
University of Kansas


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]