[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: How to create initrd.img to boot LVM-on-RAID0? (SOLVED)



: I'm having the devil of a time trying to boot off
: an  "LVM-on-RAID0" device.
: 
: I've created a software RAID-0, defined a Volume Group on in with
: (currently) a single logical volume, and copied my entire
: installation onto it, modifying the copied fstab to reflect where
: the new "/" is.
: 
: I created a new initrd with:
: 
: mkinitrd --preload raid0  --with=raid0 initrd_raid.img 2.6.22.5-76-fc7
: 
: Note: the LVM modules are getting included in the initrd "for free"
: because I'm currently running on a non-raid LV-managed file system.
: 
: I added a stanza to grub.conf for the new initrd.img.
: 
: But the thing won't boot. From the boot messages it appears to not
: be starting the array, so when it goes to scan for LVs it doesn't
: find the one that's sitting on top of the array where root lives.
: 
: Are there instructions for how to make this work?  I've googled for
: a couple of hours, tried a bunch of stuff, but can't get it to
: work.  From what I've read I suspect I must hand-tweek the "init"
: file in the initrd.
: 
: Surely there is "a right way" to do this.

Ian Comfort on the linux-raid list provded the "right way":

   mkinitrd --fstab=/newroot/etc/fstab initrd_raid.img 2.6.22.5-76-fc7

where /newroot is my LVM-on-RAID0 device.

mkinitrd is smart enough to figure out from the fstab entry
what's going on and properly create the initrd.img with the correct
modules, executables, and order of invocation.

Dean


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]