[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: java install



On Sat, 2007-10-13 at 11:41 +1000, David Timms wrote:
> michael wrote:
> > On Fri, 2007-10-12 at 17:25 +0100, michael wrote:
> >> I've had a quick lot but got confused -- is there a JRE and JDK/SDK that
> >> comes with Fedora FC7?
> >> Thanks, M
> >>
> > 
> > This is for Intel Core2 Duo, so I've downloaded AMD64 (same instruction
> > set) from java.com and then (as per
> > http://java.com/en/download/help/5000011300.xml#download) run the
> > binary:
> > 
> > 
> > mkb veri:~/src$ su
> > Password: 
> > [root veri src]# cd /usr;ls
> > bin  games    kerberos  lib64    local  share  tmp
> > etc  include  lib       libexec  sbin   src
> > [root veri usr]# cd local;ls
> > bin  games    lib    libexec     matlab_7_4_DVD  share
> > etc  include  lib64  matlab_7_4  sbin            src
> > [root veri local]# mkdir java
> > [root veri local]# cd java
> > [root veri java]# chmod a+x ~mkb/src/jre-6u3-linux-amd64-rpm.bin 
> > [root veri java]# ls -l ~mkb/src/jre-6u3-linux-amd64-rpm.bin
> > -rwxr-xr-x 1 mkb mkb 17643526 2007-10-12
> > 17:45 /home/mkb/src/jre-6u3-linux-amd64-rpm.bin
> > [root veri java]# ~mkb/src/jre-6u3-linux-amd64-rpm.bin
> > Sun Microsystems, Inc. Binary Code License Agreement
> > 
> > for the JAVA SE RUNTIME ENVIRONMENT (JRE) VERSION 6
> > 
> > SUN MICROSYSTEMS, INC. ("SUN") IS WILLING TO LICENSE THE
> > SOFTWARE IDENTIFIED BELOW TO YOU ONLY UPON THE CONDITION
> > THAT YOU ACCEPT ALL OF THE TERMS CONTAINED IN THIS BINARY
> > CODE LICENSE AGREEMENT AND SUPPLEMENTAL LICENSE TERMS
> > {snip}
> > Do you agree to the above license terms? [yes or no]
> > yes
> > Unpacking...
> > Checksumming...
> > Extracting...
> > UnZipSFX 5.50 of 17 February 2002, by Info-ZIP (Zip-Bugs lists wku edu).
> >   inflating: jre-6u3-linux-amd64.rpm  
> > Preparing...                ###########################################
> > [100%]
> >    1:jre                    ###########################################
> > [100%]
> > Unpacking JAR files...
> >         rt.jar...
> >         jsse.jar...
> >         charsets.jar...
> >         localedata.jar...
> >  
> > Done.
> > [root veri java]# ls -alt
> > total 17476
> > drwxr-xr-x  2 root root     4096 2007-10-12 17:48 .
> > drwxr-xr-x 15 root root     4096 2007-10-12 17:46 ..
> > -rw-r--r--  1 root root 17846983 2007-09-25 08:53
> > jre-6u3-linux-amd64.rpm
> > 
> > 
> > but both yum and rpm fail to do anything more (unlike the instructions):
> > 
> > [root veri java]# yum localinstall ./jre-6u3-linux-amd64.rpm 
> > Setting up Local Package Process
> > Examining ./jre-6u3-linux-amd64.rpm: jre - 1.6.0_03-fcs.x86_64
> > ./jre-6u3-linux-amd64.rpm: does not update installed package.
> > Nothing to do
> > [root veri java]# ls -alt
> > total 17476
> > drwxr-xr-x  2 root root     4096 2007-10-12 17:48 .
> > drwxr-xr-x 15 root root     4096 2007-10-12 17:46 ..
> > -rw-r--r--  1 root root 17846983 2007-09-25 08:53
> > jre-6u3-linux-amd64.rpm
> > [root veri java]# rpm -iv jre-6u3-linux-amd64.rpm 
> > Preparing packages for installation...
> >         package jre-1.6.0_03-fcs is already installed
> > [root veri java]# ls
> > jre-6u3-linux-amd64.rpm
> > [root veri java]# 
> > 
> > ie there is no jre* subdir...
> > 
> > Any ideas what's going on?
> Maybe, after a rpm -qa j\*
> 
> DaveT.
> 
I'm not sure what your question is.  You now have Java installed.  Why
are you trying to re-run rpm to install after the bin expanded the rpm
and installed it (via rpm)?

It's installed somewhere.  Open up a terminal and type "java -version"
and "which java."

I NEVER use rpm to install Java, Eclipse, FOP (if it's available as an
rpm), Hibernate, JBoss Rules, Spring, etc.  I go get the .tar.gz files.
I switch between versions of apps to stay consistent with different
clients, so I just set up links:

    /apc/Java/ant  -->  /apc/Java/apache-ant-1.6.5
    /apc/Java/apache-ant-1.6.0
    /apc/Java/apache-ant-1.6.5
    /apc/Java/jdk  -->  /apc/Java/jdk1.6.0_02
    /apc/Java/jdk1.5.0_12
    /apc/Java/jdk1.6.0_02
    /apc/Java/eclipse  -->  /apc/Java/eclipse-europa
    /apc/Java/eclipse-3.2.1
    /apc/Java/eclipse-europa

I also don't want yum to update my jdk if I don't notice it in an update
list.


-- Mark C, Allman, PMP
-- Allman Professional Consulting, Inc.
-- www.allmanpc.com, 617-947-4263

BusinessMsg -- the secure, managed, J2EE/AJAX Enterprise IM/IC solution





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]