[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Error 16: Inconsistent filesystem structure



Doug Purdy wrote:
Le dim 14/10/2007 à 21:35, Doug Purdy a écrit :
Le dim 14/10/2007 à 19:39, Mikkel L. Ellertson a écrit :
Doug Purdy wrote:
Hi Mikkel,

Here are the fdisk partitions:

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 5000 40162468+ 83 Linux
/dev/sdb2 5001 5013 104422+ 83 Linux
/dev/sdb3 5014 24321 155091510 8e Linux LVM

Partition 1 and 2 are 83 Linux and grub and the fedora .img files are in
partition 2 which I can mount. I can't mount or link to partitions 1 or
3.

To my unknowing eye it seems strange that the Fedora 7 Logical Volume
Management program shows partition 3 or VolGroup00 to be an ext3 file
system and LogVol01 to be a 2gig swap file system.

Stranger still is that VolGroup00 is 146 gigs but has only 32 megs free
after an install and the automatic updating of files.

I suspect these partitions are the original ones I created before
telling ananconda to erase everything.

Okay, now I am completely confused. I tried to boot from the hard disk
and this time it worked. Nautilus, or whatever the file browser is
called in English, now reports 131 gigs free.
But Logical Volume Management still reports VolGroup00 (sdb3) as having
32 megs free, sdb1 while a type 83 Linux partition has no filesystem and
is not mounted.

The only thing normal is that Nautilus shows the contents of sdb2 (a
type 83 Linux partition) under the /boot directory.

OK, good work. It seems:
- sdb1 is marked with a partition type ext2, but hasn't been formatted with that file system yet. To be sure, perhaps try fsck.vfat and others, which should also fail... If so depending on the size you might like to make this your /home partition. Another alternative is to mark it as LVM, then add it to the VG0, and then extend an existing or add a new LV within that space. - sdb2 is marked ext2, and has been formatted ext2, and has the normal boot files on it. - sdb3 is marked LVM. The complete space is one physical volume {LVM PV}. A VG has been created that uses that PV called VolGroup00. There are at least two Logical Volumes created within that VolGroup00. LogVol00 {guess} is 146GB ext2 mounted as /, LogVol01 is 2GB swap, and there is a tiny bit of space {32MB} that is within the PV, but is not assigned to an LV {and might be too small to do so}.
-- the space free on the LV00 ext3 partition is 131GB.

I don't know what might have made it stop being bootable, and then suddenly be bootable again. How are you telling the machine to boot from the second hard disk ? Where there any action commands issued that you can remember ?

DaveT.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]