[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Error 16: Inconsistent filesystem structure



Le mar 16/10/2007 à 05:03, David Timms a écrit :
> OK, good work. It seems:
> - sdb1 is marked with a partition type ext2, but hasn't been formatted 
> with that file system yet. To be sure, perhaps try fsck.vfat and others, 
> which should also fail... If so depending on the size you might like to 
> make this your /home partition. Another alternative is to mark it as 
> LVM, then add it to the VG0, and then extend an existing or add a new LV 
> within that space.

Thanks for sticking with me Dave. I tried fsck with vfat, msdos, ntfs,
reiser, ext 2 & 3 to no avail. I got the list of superblocks for block
sizes 1024, 2048 and 4096 but they didn't help either.

> - sdb2 is marked ext2, and has been formatted ext2, and has the normal 
> boot files on it.
> - sdb3 is marked LVM. The complete space is one physical volume {LVM 
> PV}. A VG has been created that uses that PV called VolGroup00. There 
> are at least two Logical Volumes created within that VolGroup00. 
> LogVol00 {guess} is 146GB ext2 mounted as /, LogVol01 is 2GB swap, and 
> there is a tiny bit of space {32MB} that is within the PV, but is not 
> assigned to an LV {and might be too small to do so}.
> -- the space free on the LV00 ext3 partition is 131GB.
> 
> I don't know what might have made it stop being bootable, and then 
> suddenly be bootable again. How are you telling the machine to boot from 
> the second hard disk ? Where there any action commands issued that you 
> can remember ?

Thanks for the explanation of the partitions and volumes. 

I tried changing the bios to boot from sdb but it complained that "NTLDR
is missing" and didn't get into grub. 

The Error 16 happens once in 4 reboots. I haven't been able to see any
pattern.

I used mke2fs under verbose to put ext3 on sdb1. It went through the
badblocks tests without comment. I saved the screen output to sda1, the
ntfs drive, to have a record.

Since then I get the Error 16 every reboot but in 4 of 5 tries it booted
when I selected the current kernel. The other time I had to select the
current kernel twice.

Could the problem be I seem to be using the master boot record of sda
while booting on sdb? I thought we couldn't do that? My plan was to make
sdb the boot drive but the bios is currently set for sda. Now though it
seems like I would have to install a MBR on sdb? 

Would the problems be solved if I put all partitions in fstab?

This computer is not faultless. My daughter used this computer for a few
years under XP but she had more and more problems. She became so
frustrated I bought her an iMac. Under Linux, at least this XP
computer's sound problem is less bothersome. But maybe the problem was
the computer rather than XP. I might end up buying a new computer or two
and keeping any salvageable parts.

Thanks for your help. This is quite a puzzle for someone of my
experience.

Doug


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]