[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Interesting



I have 2 hard drives and this has caused some problems now understood. Here is what happened.

Day 1: I turned off the IDE drive with this F7 and loaded F7-64 onto the new SATA drive. I let grub set up on the F7-64 so I could be sure to get it at least fully loaded. This worked and when it was up (without a pointer) I got a Terminal open and using fdisk I found that the SATA drive was at /dev/sda and the IDE was at /dev/sdb.

Tried many grub things but none seemed to work. Don't recall but I did get grub so confused it could not find a hard drive :-) So then I got the SATA drive unplugged and rebooted but still a problem. Then from a rescue cd I redid the proper grub intonation and the IDE drive booted up.

Day3: The SATA drive was plugged back in and when it came up the IDE drive was still /dev/sda. Looked for SATA and it is at /dev/sdf now. No reason known for this. I mounted the SATA on this computer and adjusted grub.conf and fstab to be at /dev/sdf and this is done.

LABELS: The SATA F7-64 uses labels and they are a real pain! I am trying to get them understood and it is hard. I guess label's are good after everything is working.

Next I am going to want to chainload the grub on the F7-64 on the SATA drive, from the grub on the IDE drive. This should be easy but I need to set up the grub on the SATA drive proper. I am going to try and get both the root and the setup to be /dev/sdf 3 and then chainload that.



--

	Karl F. Larsen, AKA K5DI
	Linux User
	#450462   http://counter.li.org.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]