[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Dhclient problem



On Tue, 23 Oct 2007 17:37:10 -0400
"Wandell, Doug" <dwandell mitre org> took out a #2 pencil and
scribbled:

> I've rolled an FC6 live cd that configures eth0 via dhcp. The
> default configuration works fine
> - /etc/sysconfig/network-scripts/ifcfg-eth0: DEVICE=eth0
> ONBOOT=yes
> BOOTPROTO=dhcp
> HWADDR=<MAC address>
>  
> In Wireshark, I see the DHCP Discover, Offer, and ACK. No problem.
>  
> As soon as I add:
> DHCLIENTARGS="-s 192.168.1.100"
>  
> to /etc/sysconfig/network, dhclient hangs indefinitely. Using
> Wireshark on the dhcp server, I can see the DHCP Discover packets
> coming in, and the server's DHCP Offer response. But the FC box
> won't accept the offer.
>  
> Anybody know what's going on here?

Have you attempted to run dhclient in the foreground to see what
it's doing or possibly spitting to the terminal? Something like

dhclient -d -s 192.168.1.100 

This should force it to stay in the foreground and you can see what
is happening. I forget where dhclient logs. I
think /var/log/messages...but if you've been muckin' around a
lot you may have to grep for the dhclient entries.

-- 
ethericalzen gmail com
Life is a prison, death is a release


I'm making some progress - It looks like dhclient cannot reply to the
server while running in -s mode due to the lack of a gateway being
configured.  I ran dhclient as you suggested - there was no output, but
while it hung, I issued a 'route add default dev eth0' in another
terminal and boom, it worked.

Somewhere in the back of my leaky brain I seem to remember a bug report
citing something similar.  Bugzilla is my next stop if I can't figure
out how to coax dhclient into setting a gateway.






-- 
fedora-list mailing list
fedora-list redhat com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]