[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: dd command to clear start of harddrive



On Thursday 25 October 2007 01:23, John Summerfield wrote:
> Nigel Henry wrote:
> > This is not directly Fedora related.
> >
> > I connect to the Internet through my Smoothwall, and a serial modem.
> > Recently the machine that the Smoothwall is running on has been playing
> > up. Harddrive spinning up and down. I have another older machine
> > (1.33GHz, 64MB RAM, and 6GB harddrive) which had Win 2000 pro on it, and
> > was trying to install a backup Smoothwall on it. The Smoothwall installs
> > ok, and lilo is installed, but when I reboot the BIOS does the memory
> > check, and all I get next is half a screenfull of "40's" printed out.
> > they remain for a few seconds, then I just get a prompt that I can't do
> > anything with.
> >
> > I am wondering if something has been left behind on the harddrive from
> > the Win 2000 install, that linux has not been able to remove.
>
> Almost certainly that is not the problem,
>
> You need to read the lilo documentation, it will probably explain to you
> exactly what is wrong.

> Cheers
> John

Thanks to Andy for the dd syntax, but sadly, although it cleared the start of 
the drive, I still couldn't get the Smoothwall to boot up post install, just 
an "L" followed by a string of 40's after the BIOS memory check. All a bit 
weird, as when I bought the machine about 4 years ago when I first started 
with computers, it had Win 98 on it, and that worked ok. I passed the machine 
onto my son, and he somehow got Win 2000 pro installed on it. I know that was 
booting ok, because I tried it. It got as far as wanting the password to get 
in, but as I don't know his password I couldn't progress further, but at 
least it was booting, so it doesn't seem to be a problem with booting from 
the harddrive. 

Could a failing cmos battery cause this sort of problem? I cycled down to town 
today, but forgot to buy a new one.

John. Lilo is possibly the problem, but I can't see how to re-install it in 
the MBR. Saying that though, on the other machine where the Smoothwall is 
working ok, there is no problem, and I couldn't be posting this if lilo was 
screwed up.

Perhaps the machine is just a piece of junk, and needs to be sent to the 
nearest dumpster, but I do like to try and resolve problems, before trashing 
what might be a useable machine.

I booted up the problem machine with the Smoothwall installed on it using 
Finnix. Running fdisk -l showed the same output as ssh'ing into my smoothwall 
that's up and running, but couldn't find a way of chrooting into the 
Smoothwall partitions from Finnix. perhaps I'm a bit out of my depth. I was 
looking to rerun /sbin/lilo just to see if it hadn't been installed in the 
MBR, and maybe that was the problem which resulted in the "L", and half a 
screen of 40's when booting up.

Perhaps I should just forget about the problem machine, and trying to install 
Smoothwall on it. My current running Smoothwall has settled down, and I can 
access the Internet from my Fedora, Debian, and other distros through it.

Thanks for the help guys.

Nigel.












[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]