[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: media descriptor issue help please [SOLVED]



On Friday 26 October 2007 04:04:20 pm Dave Stevens wrote:
> Hi,

gory details below. Top posting I know...

The drive is in good working order except for an unclean shutdown. It appeared 
in gparted after I remembered to install and use it) as /dev/sda1 so first I 
tried 

[root localhost mnt]# mount -t ntfs-3g /dev/sdb1 win
$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/sdb1': Operation not supported
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
          clicking on the 'Safely Remove Hardware' icon in the Windows
          taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
          your own responsibility. For example type on the command line:

            mount -t ntfs-3g /dev/sdb1 win -o force

    Or add the option to the relevant row in the /etc/fstab file:

            /dev/sdb1 win ntfs-3g defaults,force 0 0

which is reasonable considering there was a very unclean shutdown, and then

[root localhost mnt]# mount -t ntfs-3g /dev/sdb1 win -o force

which complained

$LogFile indicates unclean shutdown (0, 0)
WARNING: Forced mount, reset $LogFile.

but worked ok, so now I have the data. Thanks to all who helped.

Dave


>
> I have a F7 box that works fine. Recently a Windows computer was hit by a
> stray 220 volt jolt and the power supply died. I will in due course replace
> the power supply and see if the mobo is hooped, but for the moment I am
> really interested in seeing if I can recover the data off the drive. I've
> put the drive, a Seagate ATA 40 gig into the F7 drive where it lives
> alongside the primary (F7) drive, a Seagate SATA 320.
>
> The BIOS correctly detects the type and model of the ATA drive and the
> dmesg messages indicate that it is correctly detected. The BIOS messages
> state the capacity and interface correctly and say that S.M.A.R.T. is
> enabled and no errors are detected. If I set the box to boot from the ATA
> drive Windows XP tries to boot and offers a set of boot options. No matter
> which one I choose Windows starts to boot then acts as if it can't deal
> with the drastically different hardware it finds and reboots.
>
> This leads me to believe that there is recoverable data on the drive but I
> can't mount it in F7. Messages from dmesg read in part as below:
>
> ata7: PATA max UDMA/133 cmd 0x00000000000101f0 ctl 0x00000000000103f6 bmdma
> 0x000000000001ffa0 irq 14
> ata8: PATA max UDMA/133 cmd 0x0000000000010170 ctl 0x0000000000010376 bmdma
> 0x000000000001ffa8 irq 15
> ata7.00: ATA-6: ST340810A, 3.39, max UDMA/100
> ata7.00: 78165360 sectors, multi 16: LBA
> ata7.00: configured for UDMA/100
>
> The drive is jumpered and cabled as primary master
>
> A mounting attempt onto empty directory /mnt/win gives :
>
> [root localhost mnt]# mount /dev/sdb -t vfat win
> mount: wrong fs type, bad option, bad superblock on /dev/sdb,
>        missing codepage or other error
>        In some cases useful info is found in syslog - try
>        dmesg | tail  or so
>
> [root localhost mnt]#  dmesg | tail
> Bluetooth: HIDP (Human Interface Emulation) ver 1.2
> ip6_tables: (C) 2000-2006 Netfilter Core Team
> ip_tables: (C) 2000-2006 Netfilter Core Team
> Netfilter messages via NETLINK v0.30.
> nf_conntrack version 0.5.0 (8192 buckets, 65536 max)
> eth0: no IPv6 routers present
> hfs: unable to find HFS+ superblock
> hfs: unable to find HFS+ superblock
> FAT: invalid media value (0xb9)
> VFS: Can't find a valid FAT filesystem on dev sdb.
>
> So it seems that there is an invalid media descriptor on the ATA drive. But
> the information seems to not be conclusive because in fact the Windows boot
> sector is detected and a partial boot into Windows does in fact take place.
> I don't know what to make of this or what to do next.
>
> Ideas? Diagnostics?
>
> Dave
>
> --
> "Politics is not like the nursery; in politics obedience
> and support are the same." - Hannah Arendt in "Eichmann in
> Jerusalem - A Report on the Banality of Evil"



-- 
"Politics is not like the nursery; in politics obedience 
and support are the same." - Hannah Arendt in "Eichmann in
Jerusalem - A Report on the Banality of Evil"


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]