[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Preupgrade on Fedora-7



Timothy Murphy wrote:
Kevin J. Cummings wrote:

Timothy Murphy wrote:
I just resurrected an old computer running Fedora-7.
I ran "yum update" and it successfully updated 420 packages,
amounting to 850MB.
But when I yum-installed preupgrade, and then ran preupgrade,
I got the error:
-----------------------------------------------------
[tim harriet yum.repos.d]$ sudo preupgrade
Xlib: connection to ":0.0" refused by server
...
-----------------------------------------------------

Are you running as root?  Does root have access to your X-server to open
windows?  (Is X11 even running?)  the "$" prompt indicates that you are
running as a user.

Well, I did say "sudo preupgrade".
Maybe that is not enough.
And I was running X11.

Sorry, I read too fast and missed the sudo part.  B^{

ISTR that under some circumstances X11 doesn't like root connecting to your server. Check your xhost settings. I was *very* happy when emacs decided to simulate -nw when the X11 window failed to open between machines.

What does running "pre-upgrade-cli" do when run from a root account?

Thanks for the suggestion.
I'm just running
	preupgrade-cli Rawhide
and hundreds of packages are being listed for updating -
an amazing mixture of fc7, fc10 and fc11 files.
Total download size: 1.9GB.
I can't believe this will work but I'll try it ...
there are 1661 transactions being made ...

yeah, I had the same amount. You will find some conflicts with RPM versions and the like. I downloaded over 1340 packages for my small system before it died running the transaction. It would've been better if those dependencies had been caught before the download.

I tried Rawhide, F-9, and F-8. All 3 had problems. The F-8 one surprised me as I would have thought that would have been the most tested preupgrade....

I was running preupgrade-0.9.1.fc7 from updates-testing?

I couldn't install any newer versions due to installation dependencies (ye olde chicken and the egg problem).

I tried this earlier (before F10 was released) and all attempts failed
due to conflicts.

How did your attempt turn out?

--
Kevin J. Cummings
kjchome rcn com
cummings kjchome homeip net
cummings kjc386 framingham ma us
Registered Linux User #1232 (http://counter.li.org)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]