[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: gscpa_ov519 flaky in F10



On Wed, 2008-11-26 at 21:56 +0100, William Murray wrote:
> Hello all,
>               I have a camera served by the rastageeks ov51x_jpeg
> driver. With the advent of 2.6.27 kernels the gspca_ov519 which is in
> the system now gets in first. Its a great driver, with cheese or
> mplayer, but does not work with evo or kopete, the packages I want.
>    So I want to re-enable ov51x_jpeg. I blacklist gspca_ov519, fine.
> But the device /dev/video0 is enabled with root root crw-rw----
> permission, which means I cannot use it :(
>    I can chown /dev/video each time, but I wanted to do it
> once-and-for-all. However, even if I create it in /etc/rc.local it is
> overwritten when I plug in the cam.
>            Can anyone suggest what I should do? 
>                  Thank you so much!
>                        Bill
>        
Veli-Pekka Kestilä told me what to do:
 Anyway as no one has answered you in the list here is some help, you
should look /etc/udev which is configuration for udev daemon which
creates the entries for devices. You need to make rule for your device
which assigns it to right group and user and gives it necessary
permissions.

I made a new file called
/etc/udev/rules.d/50-udev.rules
with the line
KERNEL=="video*", MODE="0666"
which works nicely.

Its still a shame I had to blacklist gspca_ov519, but at least my cam
works again!
-- 
Bill Murray                     ----                       ATLAS
STFC RAL at: Bat 161 1-14, CERN,1211 Meyrin, Geneve 23, Switzerland  
     Tel:- CERN +41 22 7673028    or  RAL +44 (0)1235 446256
-- 
Scanned by iCritical.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]