[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora 10 install issues



On Saturday 29 November 2008 16:31:29 Paul W. Frields wrote:
> On Sat, Nov 29, 2008 at 03:43:37AM -0700, Kevin Kempter wrote:
> > I'm trying to instal Fedora10 on my new laptop but I've run into a few
> > issues.  
> >
> > It's a Dell Precision M6400  - I'm running KDE
> >
> > I have 2 issues:
> >
> > 1) I cannot get the full screen resolution
> > I can go to administration --> display and under the 'Hardwae' tab I can
> > configure the display as a generic or as a Dell 1920x1200 but no matter
> > what I choose the 'Settings' tab only lets me choose a max of 1400x1050
>
> You may need to generate an xorg.conf file.  I prefer to install the
> 'system-config-display' package, and then as root run
> 'system-config-display --reconfig'.  Select your proper monitor from
> the list.  When you're done, edit the 'Modes' line in the "Screen"
> section to include a mode for your actual resolution.
>
> > 2) system notification sound works, and rhythmbox sound works but no
> > other sound / players work such as amaok or Kaffiene
>
> I don't have any real KDE skills so I can't help you with this one.
> Anyone else?

I installed the nvidia driver like this:

1) I installed the rpmfusion repos
2) I did a yum install kmod-nvidia
3) I ran nvidia-xconfig (to generate my xorg.conf file)

Still no luck. - my current xorg.conf file is below

I also tried running system-config-display --reconfig  with no change in 
results.


I tried adding a Modes section to the Screen section like this:


Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       24
        Modes "1920x1200"
    EndSubSection
EndSection


but still no luck. If it matters, I installed CentOS and it immediately (even 
without installing the nvidia drivers) gave me 1920x1200 - not sure if this is 
helpful or not but it confirms that the card actually will run 1920x1200


Anyone have any other Ideas?

Thanks in advance...




# cat /etc/X11/xorg.conf          
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister builder58)  Tue Nov  4 17:18:57 
PST 2008                                                                          

# Xorg configuration created by system-config-display

Section "ServerLayout"
    Identifier     "single head configuration"
    Screen      0  "Screen0" 0 0              
    InputDevice    "Mouse0" "CorePointer"     
    InputDevice    "Keyboard0" "CoreKeyboard" 
EndSection                                    

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0" 
    Driver         "mouse"  
    Option         "Protocol" "auto"                                            
    Option         "Device" "/dev/input/mice"                                   
    Option         "Emulate3Buttons" "no"                                       
    Option         "ZAxisMapping" "4 5"                                         
EndSection                                                                      
                                                                                
Section "InputDevice"                                                           
                                                                                
# keyboard added by rhpxl                                                       
    Identifier     "Keyboard0"                                                  
    Driver         "kbd"                                                        
    Option         "XkbModel" "pc105+inet"                                      
    Option         "XkbLayout" "us"                                             
EndSection                                                                      
                                                                                
Section "Monitor"
    Identifier     "Monitor0"
    ModelName      "LCD Panel 1920x1200"
    HorizSync       31.5 - 74.5
    VertRefresh     56.0 - 65.0
    Option         "dpms"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       24
    EndSubSection
EndSection



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]