[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re:B&W Awstats Reports



1- My Apache web server is working now.

 

2- I unistalled awstats-6.8-1.noarch.rpm and installed awstats with “yum install awstats” and it worked fine.

 

3 – This is /etc/awstats/*.conf :

 

# AWSTATS CONFIGURE FILE 6.6

LogFile="/var/mylog/access.log"

LogType=W

LogFormat=1

LogSeparator=" "

SiteDomain="nature.com"

HostAliases="nature www.nature 127.0.0.1 localhost"   ///**** this line looks strange!

 

DNSLookup=2

DirData="/var/lib/awstats"

DirCgi="/awstats"

 

DirIcons="/awstatsicons"                            ///**** Alias /awstatsicons "/usr/share/awstats/wwwroot/icon/" path is O.K.

AllowToUpdateStatsFromBrowser=0

AllowFullYearView=2

EnableLockForUpdate=1

DNSStaticCacheFile="dnscache.txt"

DNSLastUpdateCacheFile="dnscachelastupdate.txt"

SkipDNSLookupFor=""

AllowAccessFromWebToAuthenticatedUsersOnly=0

AllowAccessFromWebToFollowingAuthenticatedUsers=""

AllowAccessFromWebToFollowingIPAddresses=""

CreateDirDataIfNotExists=0

BuildHistoryFormat=text

BuildReportFormat=html

SaveDatabaseFilesWithPermissionsForEveryone=0

PurgeLogFile=0

ArchiveLogRecords=0

KeepBackupOfHistoricFiles=0

DefaultFile="index.html"

SkipHosts="127.0.0.1"

SkipUserAgents=""

SkipFiles=""

SkipReferrersBlackList=""

NotPageList="css js class gif jpg jpeg png bmp ico swf"

ValidHTTPCodes="200 304"

ValidSMTPCodes="1 250"

AuthenticatedUsersNotCaseSensitive=0

URLNotCaseSensitive=0

URLWithAnchor=0

URLQuerySeparators="?;"

URLWithQuery=0

URLWithQueryWithOnlyFollowingParameters=""

URLWithQueryWithoutFollowingParameters=""

URLReferrerWithQuery=0

WarningMessages=1

ErrorMessages=""

DebugMessages=0

NbOfLinesForCorruptedLog=50

WrapperScript=""

DecodeUA=0

MiscTrackerUrl="/js/awstats_misc_tracker.js"

UseFramesWhenCGI=1

 

DetailedReportsOnNewWindows=1

 

Expires=3600

MaxRowsInHTMLOutput=1000

Lang="auto"

DirLang="./lang"

ShowMenu=1                                                 

IncludeInternalLinksInOriginSection=0

 

ShowLinksOnUrl=1

UseHTTPSLinkForUrl=""

 

 

#-----------------------------------------------------------------------------

# PLUGINS

#-----------------------------------------------------------------------------

 

LoadPlugin="geoip GEOIP_STANDARD /usr/local/share/GeoIP/GeoIP.dat"

ExtraTrackedRowsLimit=500

 

4- This is /etc/httpd/conf.d/awstats.conf :

 

#

# Content of this file, with correct values, can be automatically added to

# your Apache server by using the AWStats configure.pl tool.

#

 

#

# Directives to add to your Apache conf file to allow use of AWStats as a CGI.

# Note that path "/usr/share/awstats/" must reflect your AWStats install path.

#

Alias /awstatsclasses "/usr/share/awstats/wwwroot/classes/"

Alias /awstatscss "/usr/share/awstats/wwwroot/css/"

Alias /awstatsicons "/usr/share/awstats/wwwroot/icon/"

ScriptAlias /awstats/ "/usr/share/awstats/wwwroot/cgi-bin/"

 

#

# This is to permit URL access to scripts/files in AWStats directory.

#

<Directory "/usr/share/awstats/wwwroot">

    Options None

    AllowOverride None

    Order allow,deny

    Allow from 127.0.0.1

</Directory>

# Additional Perl modules

<IfModule mod_env.c>

    SetEnv PERL5LIB /usr/share/awstats/lib:/usr/share/awstats/plugins

</IfModule>

 

 

5 – I think I am close but still my reports are black & white , I miss icons !

 

6- I generate reports with the following command:

perl awstats.pl –config=mysite –output=alldomains –staticlinks > awstats.mysite.alldomains.html

 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]