[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Yum error on rpmfusion



Kevin Kempter wrote:
On Tuesday 02 December 2008 15:14:24 Jim wrote:
FC10/KDE

I have the rpmfusion repo setup,but I get a yum error message:

Could not retrieve mirrorlist
http://mirrors.rpmfusion.org/mirrorl...d-10&arch=i386
<http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-updates-released-
10&arch=i386> error was
[Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Error: Cannot retrieve repository metadata (repomd.xml) for repository:
rpmfusion-free-updates. Please verify its path and try again

Does anyone not what know what is going on ??
Re-run the rpm -Uhv commands here:
http://fedorasolved.org/post-install-solutions/yum-config

I have tried a number of times to install the rpmfusion repos but I keep getting this error.


# rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm Retrieving http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
curl: (6) Couldn't resolve host 'download1.rpmfusion.org'
error: skipping http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm - transfer failed Retrieving http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
curl: (6) Couldn't resolve host 'download1.rpmfusion.org'
error: skipping http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm - transfer failed



Here is were I ran dig, nslookup, and ping, and appears that I'm having problems of getting through my router. If I run Firefox I have no problems getting through the router Gateway 172.16.0.1 , resolv.conf 172.16.0.1 . I 'am running a FC 8 box on this same router AT&T (2Wire783) and I'm having the same problem.
Even if I pin yahoo.com I get the same error.
Yum doesn't have any problems of updating through this router.
What in my router could be causing this problem ?



# dig http://download1.rpmfusion.org/free/fedora/ ; <<>> DiG 9.5.1b3-RedHat-9.5.1-0.9.b3.fc10 <<>> http://download1.rpmfusion.org/free/fedora/ ;; global options: printcmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 33071 ;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0 ;; WARNING: recursion requested but not available
;; QUESTION SECTION:
;http://download1.rpmfusion.org/free/fedora/. IN        A

;; AUTHORITY SECTION:
. 10800 IN SOA A.ROOT-SERVERS.NET. NSTLD.VERISIGN-GRS.COM. 2008120300 1800 900 604800 86400
;; Query time: 576 msec
;; SERVER: 172.16.0.1#53(172.16.0.1)
;; WHEN: Wed Dec  3 13:26:00 2008
;; MSG SIZE  rcvd: 136

[root eeePC jim]# nslookup http://download1.rpmfusion.org/free/fedora/
;; Got recursion not available from 172.16.0.1, trying next server
;; Got recursion not available from 172.16.0.1, trying next server
;; Got recursion not available from 172.16.0.1, trying next server
Server:         172.16.0.1
Address:        172.16.0.1#53

** server can't find http://download1.rpmfusion.org/free/fedora/.gateway.2wire.net: REFUSED

[root eeePC jim]# ping http://download1.rpmfusion.org/free/fedora/
ping: unknown host http://download1.rpmfusion.org/free/fedora/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]