[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Blackberry 8830 with Network Manager



On Wed, 2008-12-03 at 11:11 -0800, Rick Stevens wrote:
> Christopher A. Williams wrote:
> > I'm trying to figure out how to get my tethered Blackberry 8830 to work
> > as a modem with Network Manager. Sprint is my carrier and I have their
> > Linux modem setup document. It's straight forward.
> > 
> > The only thing missing is that Network Manager doesn't recognize my BB
> > as a modem.
> > 
> > I know I could set up kppp or gnome-ppp to make the connection, but I
> > would prefer to use Network Manager.
> > 
> > Ideas on how to make this work?
> 
> I use XmBlackBerry for this purpose, but I'm on Verizon and was running
> it under F8.  Haven't tried F9 or F10 with it yet.  I do have F9 on my
> laptop (where I used the Blackberry as a wireless modem), but
> XmBlackBerry is still installed there.  I'd have to do some checking.
> 
> You most certainly will need the barry and barry-libs RPMs to have the
> device recognized by hal and such.

I have the barry packages installed from the F10 repos. When I ran F9, I
used barry as well and configured it for my carrier (Sprint) using
Gnome-ppp. It then "magically" showed up in NetworkManager and just
worked.

On F10, Gnome-ppp seems to have been pulled. Barry now sets the modem up
on /dev/pts/0 (or 1 or 2 - seems to be on the fly). Then I'm unable to
use kppp to connect. Configuring directly through NetworkManager has not
worked for me at all.

There's a script that comes with Barry that allegedly connects up Sprint
automatically. After running it, it appears to connect, but none of my
apps seem to be able to use it.

It seems hal-info has what it needs to recognize the sdram card as a
drive, and even put mp3s on it. But we're sitting at squat for using it
as a broadband modem. Maybe I should Bugzilla that part. Not sure if
that will help though - my other hal-info bugzilla bug for my Sierra
Wireless broadband card (AT&T USB Connect Mercury) is still sitting
unassigned despite my being asked to create it.

If I could just figure out how to create an entry in modems.fdi
(in /etc/hal/information/). Ideas???

Cheers,

Chris


-- 
Christopher A. Williams <chriswfedora cawllc com>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]