[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F-10 Keyboard errors -



Bob Goodwin wrote:
Bob Goodwin wrote:

I have a problem with the F-10 keyboard producing the wrong codes. XEV displays keycode 104 when I press the down arrow on this F-9 box but on the F-10 box it shows 116. 116 is normally one of the Windows keys [next to the RH ALT key] which I normally have mapped [via xkeycaps] to produce a degree symbol.

I tell xkeycaps that it's a PC 104 key keyboard and things usually work, not with F-10, I press the down cursor key and get a degree symbol!

Any suggestions appreciated.

Bob



Marcelo Magno T. Sales wrote:

I also had problems with keyboard layouts in X after installing F10. Not your specific situation, but you may want to take a look at bug https://bugzilla.redhat.com/show_bug.cgi?id=470153 to see the problem and the solution. It may give you some idea on how to fix yours.

[]'s
Marcelo


No, I didn't find anything helpful there, language is already set correctly as US English.

But I have proved that the problem is triggered when xmodmap is run. If I run it to remap just one key it appears my keyboard layout is corrupted and worst of all remapping the RH Windows key [#116] to the degree┬░ symbol renders the down cursor key [#104] useless, it becomes a degree key in addition to 116?

This is only a problem on the F-10 computer. These are changes I have made routinely in every version of Fedora!

I will put off upgrading this F-9 computer for a while since that problem precludes such things as disabling the Caps Lock key and I am a lousy typist.

Bob



   This morning I tried booting the computer from the F-9 Live Gnome CD
   and things appear to work normally after I enter  /usr/bin/xmodmap
   -e 'keycode 116=degree'

   The Windows key to the right of the right hand ALT key now produces
   a "┬░" [degree] symbol while the cursor down arrow key still
   functions normally.

   It would be informative if someone else running F-10 would try
   duplicating my problem by entering:
   /usr/bin/xmodmap -e 'keycode 116=degree' and see if they get the
   degree symbol and if the down arrow still works normally?

   The F-10 in question was installed from the live CD but I would not
   expect that to make any difference.

   Thanks.

   Bob



/usr/bin/xmodmap -e 'keycode 116=degree'


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]