[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Errors installing Cisco VPN



2008/12/5 Christopher A. Williams <chriswfedora cawllc com>:
> On Thu, 2008-12-04 at 18:39 -0700, Kevin Kempter wrote:
>> Hi All;
>>
>> I got the latest vpnclient download from cisco -I'm running 64bit Fedora 10
>>
>> I un-tarred the vpnclient-linux-x86_64-4.8.00.0490-k9.tar.gz (as root) in the
>> /opt dir
>>
>> then in the new vpnclient dir I ran this:
>>
>> ./vpn_install
>>
>> and after following the prompts I get this error:
>>
>> Making module
>> make -C /lib/modules/2.6.27.5-117.fc10.x86_64/build SUBDIRS=/opt/vpnclient
>> modules
>> make[1]: Entering directory `/usr/src/kernels/2.6.27.5-117.fc10.x86_64'
>> scripts/Makefile.build:46: *** CFLAGS was changed in "/opt/vpnclient/Makefile".
>> Fix it to use EXTRA_CFLAGS.  Stop.
>> make[1]: *** [_module_/opt/vpnclient] Error 2
>> make[1]: Leaving directory `/usr/src/kernels/2.6.27.5-117.fc10.x86_64'
>> make: *** [default] Error 2
>> Failed to make module "cisco_ipsec.ko".
>
> <snip...>
>
>>
>> Thoughts ?
>
> The Cisco vpn client is *very old* software. It hasn't worked out of the
> box in several years because they continue to make depricated system
> calls and just generally don't keep up with kernel updates.
>
> I'm sure someone will come up with another work-around in the code to
> make the newest kernel work fairly soon.
>
> Otherwise, I would advise that unless you have a specific need for the
> Cisco client, use the Cisco VPN client plugin that comes with
> NetworkManager (NetworkManager-vpnc). It will import settings from a
> cisco .pcf configuration file and works impressively well. The only time
> I haven't been able to use it with a Cisco VPN gateway was almost 3
> years ago with an old employer who was using a vpn tunneling setting
> that was considered old back then.
>
> Cheers,
>
> Chris
>
> --
> ==================================
> By all means marry;
> If you get a good wife, you'll be happy.
> If you get a bad one, you'll become a philosopher.
>
> --Socrates
>
> --
> fedora-list mailing list
> fedora-list redhat com
> To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
> Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines
>

I installed
vpnc-0.5.1-6.fc9.i386
openvpn-2.1-0.29.rc15.fc9.i386
NetworkManager-vpnc-0.7.0-0.11.svn4326.fc9.i386
openvpn-auth-ldap-2.0.3-3.fc9.i386
 and got the mesage "VPN1 cannot start because the VPN Service failed to start"

i also need this *really very old* client to make it work with kernel
2.6. any suggestions in order to make my connection work?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]