[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Upgrade from F9 -> F10 xorg.conf problem



Steven W. Orr wrote:
Steven W. Orr wrote:
I upgraded from F9 to F10. In my xorg.conf I had this set:

Section "InputDevice"
       Identifier "Keyboard0"
       Driver      "kbd"
       Option      "XkbModel" "pc105"
       Option      "XkbLayout" "us"
       Option      "XkbOptions" "ctrl:swapcaps"
EndSection

The ctrl:swapcaps no longer seems to take. i.e., I want my ctrl and capslock to be switched.

Any ideas?

This is probably caused by the switch to evdev for input.  You might
have better luck setting the options via hal, with something like this
in /etc/hal/fdi/policy/11-keymap.fdi:

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
    <device>
        <match key="info.capabilities" contains="input.keys">
<merge key="input.xkb.options" type="string">ctrl:swapcaps</merge>
        </match>
    </device>
</deviceinfo>

And then you should be able to remove the InputDevice section in
xorg.conf (or remove xorg.conf entirely).

---------Me again-------------------
I tried this and didn't get anywhere. What I did was to create /etc/hal/fdi/policy/11-keymap.fdi
followed by
/etc/init.d/haldaemon restart
and then relogging in.

Also, I note that in the man page for evdev, there is no option for XkbOptions.

I think I'm close. Any suggestions?

Also, I have an old .Xmodmap file to do the same thing that now fails to pass through the xmodmap program.

Here's the screen:

524 > cat .Xmodmaprc-20050222 remove mod1 = Meta_L
remove mod1 = Meta_R
remove mod1 = Alt_L
remove mod1 = Alt_R
remove mod4 = Alt_L
remove mod4 = Alt_R
remove mod4 = Meta_L
remove mod4 = Meta_R
keycode 64 = Meta_L
keycode 113 = Meta_R
keycode 115 = Alt_L
keycode 116 = Alt_R
add mod1 = Meta_L
add mod4 = Alt_L
!
! Swap Caps_Lock and Control_L
!
remove Lock = Caps_Lock
remove Control = Control_L
keysym Control_L = Caps_Lock
keysym Caps_Lock = Control_L
add Lock = Caps_Lock
add Control = Control_L

!
! Set up the mouse
!
!pointer = 1 2 3 4 7 6 5
pointer = 1 2 3 7 6 4 5
525 > xmodmap < !$
xmodmap < .Xmodmaprc-20050222
xmodmap:  up to 3 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x69)
mod1        Alt_L (0x40),  Alt_R (0x6c),  Meta_L (0xcd)
mod2        Num_Lock (0x4d)
mod3 mod4 Super_L (0xce), Hyper_L (0xcf)
mod5        ISO_Level3_Shift (0x5c),  Mode_switch (0xcb)

526 >
This problem is preventing me from installing F-10 on this computer.

I have a script that runs:

   /usr/bin/xmodmap -e 'keycode 116=degree'

   /usr/bin/xmodmap -e 'keycode 117=mu'

   /usr/bin/xmodmap -e 'keycode 66=NoSymbol'

When I run of those in the F-10 computer it corrupts the keyboard mapping, the worst thing is that the down arrow key prints a "°" degree symbol to the screen with the first command which should change a Windows key to "°".
I am satisfied if I can simply disable the Caps Lock key.

I will be watching responses to your problem.

Bob Goodwin



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]