[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: How can I open-with over an NTFS filesystem?

Dan Thurman wrote:

I have via Nautilus (Places->)Network, mounted a remote NTFS
file-system from a Windows Server and it brings up the Nautilus
Browser showing the contents of the file to be viewed.

What I would like to do is to do a 'tail' on a log file therein which
is a text-file that has embedded ANSI Color Escape Sequences (ACES)
(of which tail is the only application that I know of that supports ACES)
but for some reason or another I simply cannot open the ACES file with
a custom tail or with any application provided by the items in the
Open-With menu.

If tried to use 'Open-with: "Text Editor"' (which 'gedit'), I get the
following error message:

Could not open the file /home/dant/.gvfs/d$ on o…ventSink/Logs/Tracker.log
using the Unicode (UTF-8) character coding.

I tried all sorts of other locales, but nothing I tried seemed to work.

I noted, that gedit had no problems opening a non-ACES log file
right next to the ACES and it worked. So it seems that ACES
is a problem with the editors that I have tried.

So, I copied over the ACES file from the NTFS filesystem onto my
desktop, and tried to open this ACES file with gedit, and it crashed
quite horribly - and it did however popped up a dialog box saying
in effect that the file in question was not a text file, but a binary

The next thing I tried was to open a Gnome terminal window, and
issue a tail -f Desktop/Tracker.log and no problems, it worked - just
that I haven't figured out how to do this over the mounted NFTS

So, my question is, with what application can I use, if any, that supports
ACES, preferably with a tail?

Kind regards,
Hmm... with a stroke of luck, I discovered that with wildcards, I solved my problem
like this:

tail -f $HOME/.gvfs/d*/Prog*/Exch*/Event*/Lo*/Tracker*

I noted, that if I tried to type in the full pathname explicitly, all bets are off, and this is where the wild-card (*) came in handy. I wonder why though, that I could
not type in the pathname explicitly.  But hey, whatever - it worked!

Kind regards!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]