[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: asus w5f Intel sound on Fedora 10



On Tuesday 09 December 2008 15:47, sfilippo wrote:
> Hi there,
> I would really appreciate any help on the following issue.
> I own an ASUS W5F with an Intel motherboard, the output from lspci is
> below. The computer has had both Fedora 6 and Fedora 7 working; since
> Fedora 8 I tried upgrading and/or fresh install  (in a separate partition)
> and/or live CD for FC8, FC9 and FC10  but I cannot get the sound subsystem
> to work. The closest I can get (today) is the gnome-sound-properties to
> open and show the test-sound "pipeline" progress bar working, but no sound
> in the earphones. This cannot possibly be a hardware problem because sound
> works OK under FC7. I tried many of the hints given on pulseaudio/alsa, but
> could not get things to work. The maddening thing is that I didn't have to
> do anything at all to have it working under FC7, it just run out of the
> box. More annoying is that under FC10 the wifi card works with the default
> distribution, which it didn't do under F7.
>
> Soooo, what's so special about this machine that gets forgotten by
> subsequent releases???? Any info needed to try to debug?
> As I said, I normally work from the FC7 partition, so comparing the two
> configurations is a very easy task.
>
> Help, please ??????
>
> Salvatore
> [sfilippo localhost [1] ~]$ /sbin/lspci
> 00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
> Controller #1 (rev 02) 00:1d.1 USB Controller: Intel Corporation 82801G

Ola Salvatore.

As this only happened since F8, I'd suspect Pulseaudio, and I did have 
problems with Pulseaudio with F8 on one machine. No sounds, but as soon as I 
disabled Pulseaudio, the sounds came back. To disable it, simply remove the 
package, alsa-plugins-pulseaudio.
yum remove alsa-plugins-pulseaudio

With the package above still installed, open alsamixer in a terminal as user. 
You will only see one slider, the pulseaudio one. Open alsamixer as below, 
and you will see all controls available for the soundcard.

alsamixer -D hw:0

There may be something that is now muted since F8, and needs to be unmuted 
(the M key toggles the mute/unmute). Left, and right arrow keys for scrolling 
through the controls. Some may need to be pushed up. The usual ones are, 
Master, PCM, Front, CD, if they exist. If a switch (external amplifier, or 
external speaker) exists, try toggling that, while some audio app is playing 
something.

Would you post the output from the following commands please.

cat /proc/asound/cards
grep ^Codec /proc/asound/card?/codec*
/sbin/lsmod | grep snd

All the best.

Nigel.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]