[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: I need Miredo for F10



Robert Moskowitz wrote:
And http://rpmfind.net/linux/rpm2html/search.php?query=miredo&submit=Search+...&system=&arch= only finds it for F9. So I download that anyway and try to do a yum localinstall and it needs:

libcap.so.1

And libcap.so.2 is installed, what to do?

I just did some further investigation and discovered that:

F8 has: libcap-1.10-30.i386
	 which contains:
		/lib/libcap.so.1
		/lib/libcap.so.1.10

F9 has: libcap-2.06-4.fc9.x86_64
	which contains:
		/lib64/libcap.so.1
		/lib64/libcap.so.1.10
		/lib64/libcap.so.2
		/lib64/libcap.so.2.06

and F10 has: libcap-2.10-2.fc10.i386
	which only has:
		/lib/libcap.so.2
		/lib/libcap.so.2.10

It looks to me like the package maintainer is plating games with the packaging in order to effect a migration forward. You probably need to file an RFE in order to get libcap.so.1 put back into the F10 RPMs.
(or maybe call it a bug since it was in F9 and isn't anymore).

I hate it when people remove stuff in the name of progress which breaks something else. Compatibility should reign forever.

Is it possible to find a newer version of Miredo with better package requirements? (I know nothing about Miredo.)

--
Kevin J. Cummings
kjchome rcn com
cummings kjchome homeip net
cummings kjc386 framingham ma us
Registered Linux User #1232 (http://counter.li.org)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]