[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

yum does not recognize correct Fedora version



I attempted an upgrade from Fedora 8 to Fedora 9 which did not succeed.
After copying had completed, many old files remained and the new kernel
was not copied. I tried to complete the upgrade using yum, but it initially
did not work because libnss and associated files were missing. After I
replaced these files from the rescue disk. I tried yum again, but 
it refuses to recognize the new version.

I have done the following:

1. yum clean all
2  Downloaded fedora-release-9-5.transition.noarch.rpm and installed it
3. Checked that rpm -qf /etc/fedora-release reports the correct version.

However, when I try:
           'yum update'
or
          'yum update kernel*'

nothing happens because it still seems to think that I have Fedora 8,
not 9.

I've thought of hard coding fedora-updates.repo, but I'm not exactly sure
what values to use for $releasever and $basearch

Other than starting over, does anyone have a suggestion how to get yum
to see the correct version? 

DS


      __________________________________________________________________
Ask a question on any topic and get answers from real people. Go to Yahoo! Answers and share what you know at http://ca.answers.yahoo.com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]