[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Script errors while livecd-creator is running yum



On Wed, 10 Dec 2008 13:13:41 -0600, Bruno wrote:

> > Typically, gtk-update-icon-cache is treated as optional in package
> > scriptlets:
> > 
> > touch --no-create /usr/share/icons/hicolor
> > if [ -x /usr/bin/gtk-update-icon-cache ]; then
> >   /usr/bin/gtk-update-icon-cache --quiet /usr/share/icons/hicolor || :
> > fi
> > 
> > Perhaps powermanga does it differently.
> 
> If so then it needs a Requires(pre): gtk2 

No, it's supposed to be optional with no dependency on gtk2.
As in "if the gtk2 tools are available, run them", else don't run them.
The -x check and the '|| :' are important.

If powermanga doesn't use gtk2 at run-time, it doesn't need to require
it for the scriptlets either.

> I'll be looking at these cases
> more carefully and try to get bugs filed against the appropiate packages.
> 
> I plan to look through all of the installs for errors. There is one segment
> fault, that I am not sure of, but maybe that was caused by a broken previous
> install or being installed out of order as well.
> 
> I don't suppose the Requires(pre) info is prominently displayed in the
> packaging guidelines (especially the coreutils case)?

https://fedoraproject.org/wiki/Packaging/ScriptletSnippets
explains it.

-- 
Michael Schwendt
Fedora release 10 (Cambridge) - Linux 2.6.27.5-117.fc10.i686
loadavg: 1.06 1.07 1.14


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]