[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpm problem, now mplayer/gpm is busted :-(



On Wed, 10 Dec 2008 17:01:44 -0500 (EST), Steven wrote:

> Somehow I have the following packages installed:
> 
> mplayer-gui-1.0-0.103.20080903svn.fc10.i386
> gnome-mplayer-0.9.2-2.fc10.i386
> mplayer-1.0-0.103.20080903svn.fc10.i386
> gnome-mplayer-common-0.9.2-2.fc10.i386
> 
> The problem is that when I try to run mplayer, it does with:
> 
> 529 > mplayer Happy_Penguin.wmv
> mplayer: error while loading shared libraries: libgpm.so.1: cannot open 
> shared object file: No such file or directory
> 
> I have a libgpm.so.2 that comes with the latest 
> gpm-devel-1.20.5-1.fc10.i386
> 
> The gpm libs I have are:
> 
> [root saturn ~]# ls -l /usr/lib/libgpm*
> -rw-r--r-- 1 root root 25856 Jul 17 06:29 /usr/lib/libgpm.a
> lrwxrwxrwx 1 root root    15 Dec  7 19:21 /usr/lib/libgpm.so -> libgpm.so.2.1.0
> lrwxrwxrwx 1 root root    15 Dec  7 19:18 /usr/lib/libgpm.so.2 -> libgpm.so.2.1.0
> -rw-r--r-- 1 root root 59446 Jul 17 06:29 /usr/lib/libgpm.so.2.1.0
> 
> [root saturn ~]# rpm -qa | grep gpm
> gpm-1.20.5-1.fc10.i386
> gpm-devel-1.20.5-1.fc10.i386
> 
> And, when I run ldd, I get this:
> 
> 533 > ldd /usr/bin/mplayer | grep gpm
>          libgpm.so.1 => not found
> 
> Is it me or is there a problem?

$ ldd /usr/bin/mplayer|grep gpm
        libgpm.so.2 => /usr/lib/libgpm.so.2 (0x004d5000)

Can you show a bit more about your /usr/bin/mplayer?
"ll /usr/bin/mplayer && rpm -V mplayer"
"mplayer | head -5"


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]