[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Cannot configure graphical mode - FC10



Hi all 

I am trying to install FC10 on a desktop machine. I replaced an existing FC7
HDD with a scratch HDD. Otherwise the hardware is identical, and FC7 worked
ok.

For some reason I cannot get it to work in graphical mode. I get past the
media test, then anaconda starts, then I get an unreadable screen with
'Back' and 'Next' buttons. I click 'Next', and get a badly messed-up
'Language' screen. I click 'Next' and get a badly messed-up 'Keyboard'
screen. I click 'Next', a 'Warning' dialog appears, with no text, and the
machine hangs.

I started again and installed in text mode, successfully. I am now trying to
configure X. I am no expert, and I could not find any information on the
Fedora site, so I am using the information from X.org.

First I typed 'X -configure'. This created a file called
'/root/xorg.conf.new'. It seems to detect the on-board VGA card ok - it
shows it as an Intel 82845G/GL. It does not pick up any information about
the monitor - it just fills in defaults for the identifier, vendor name, and
model name.

Following the instructions on X.org, I typed 'X -config
/root/xorg.conf.new'. It tries to start a graphical screen, nothing appears,
and then the machine hangs. After some experiments, I found that if I
uncomment NoAccel, it still does not work, but it does not hang. If I return
to tty1, the last line shows 'intel(0): Failed to init memory manager'.

The monitor is actually an Ultra DT-1454D. I got the specs from the web and
manually entered HorizSync and VertRefresh into xorg.conf.new and tried
again, but it made no difference.

Other things I have tried -

1. To check that the hardware has not gone faulty, I booted off my old FC7
dvd, and told it to do a fresh install. It brings up the media check in text
mode, then starts anaconda, and then continues with the install in graphics
mode with no problem. I did not continue past that point, it was just to
prove that the hardware was ok.

2. I ran 'yum install system-config-display'. It downloaded ok, but when I
run it, it uses a HUGE font, and all I can see is 'Settings' and half of
'Hardware'. I cannot scroll the screen, so I cannot do anything useful
there.

3. I tried re-installing using 'lowres' mode, but it behaved the same as
previously.

4. I ran 'yum upgrade'. After battling with PackageKit dependencies I
eventually got it to upgrade successfully, but it made no difference.

Does anyone have any suggestions?

Thanks in advance

Frank Millman


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]