[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: f9 without pulseaudio.



On Sun, Dec 14, 2008 at 1:19 PM, Reg Clemens <reg dwf com> wrote:
>> On Sun, Dec 14, 2008 at 12:56 AM, Reg Clemens <reg dwf com> wrote:
>> > I keep reading comments on this list that one can remove pulseaudio
>> > from f9 and it will run like a normal alsa system.
>> >
>> > I have removed
>> >        alsa-plugins-pulseaudio
>> >    and libflashsupport
>> >
>> > from my f9 system, rebooted.
>> > Sound in Flash in Firefox works just fine, but aplay doesn't.
>> > If aplay doesn't work I wonder about mplayer, totem, and the other sound
>> > producing programs that I havent tested.
>> >
>> > So, is there anything else I should be removing to get back to
>> > 'just alsa' ????
>> >
>> > I would really like to understand what is going on here.
>>
>>
>> It was very easy for me, here is the relevant portion of my yum.log
>> from when i removed it:
>> Sep 20 02:09:44 Erased: alsa-plugins-pulseaudio
>> Sep 20 02:09:44 Erased: pulseaudio-module-x11
>> Sep 20 02:09:44 Erased: pulseaudio
>> Sep 20 02:09:49 Erased: pulseaudio-module-zeroconf
>> Sep 20 02:09:49 Erased: pulseaudio-module-gconf
>> Sep 20 02:09:50 Erased: kde-settings-pulseaudio
>> Sep 20 02:09:50 Erased: pulseaudio-esound-compat
>>
>
> Thanks, I should have thought of that.
> I already had a 'rpm -qa | sort > rpms.list.f9' that I could have
> looked at...
>
> In any case, I removed all the modules I found in the above list,
> rebooted, and as ME, I have no audio in either aplay nor firefox.
> Doing a su and trying again, I have audio both places, so it seems
> that there is still a permission problem somewhere.
>
> Here is the output from aplay
>
> [reg deneb AU]$ aplay wheee.au
>
> ---
>
> ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
> ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: No such fi
> le or directory
> ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
> ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: No such file or
>  directory
> ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
> ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or
> directory
> ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
> ALSA lib pcm.c:2184:(snd_pcm_open_noupdate) Unknown PCM default
> aplay: main:583: audio open error: No such file or directory
>
>
> ---
>
> Any further thoughts???
> If I could get some sound working, I could move to f9.


I can't say I know what is going on, sorry. Maybe you can get some
further help at irc://freenode.net/fedora


-- 
Fedora 9 : sulphur is good for the skin
( www.pembo13.com )


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]