[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Looks gnome-packagekit dependency is broken




Well here is my experience:
rpm -i PackageKit-0.3.12-1.fc9.i386.rpm \
gnome-packagekit-0.3.12-3.fc9.i386.rpm

error: Failed dependencies:
	PackageKit-glib = 0.3.12-1.fc9 is needed by
PackageKit-0.3.12-1.fc9.i386
	PackageKit-udev-helper = 0.3.12-1.fc9 is needed by
PackageKit-0.3.12-1.fc9.i386
	PackageKit-yum = 0.3.12-1.fc9 is needed by PackageKit-0.3.12-1.fc9.i386
	PackageKit-yum-plugin = 0.3.12-1.fc9 is needed by
PackageKit-0.3.12-1.fc9.i386
	libpackagekit-glib.so.11 is needed by PackageKit-0.3.12-1.fc9.i386
	PackageKit-libs >= 0.3.11 is needed by
gnome-packagekit-0.3.12-3.fc9.i386
	libpackagekit-glib.so.11 is needed by
gnome-packagekit-0.3.12-3.fc9.i386

Where did you get these dependencies.
I don't remember step by step. As I remember now I did following things.

First, I removed PackageKit.
# rpm -e PackageKit gnome-packagekit PackageKit-glib \
PackageKit-udev-helper \
PackageKit-yum PackageKit-gstreamer-plugin \
PackageKit-yum-plugin

Then I installed package kit.
# yum install PackageKit
# yum update

Then I could not install gnome-packagekit. So I emailed here. And I downloaded package from here.
https://admin.fedoraproject.org/updates/F10/FEDORA-2008-11078

Couple days after I installed this package is updated from repository so I guess that this problem is fixed.

So you should just use yum.

Otgonbayar.A


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]