[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC9 - recent upgrade breaks NFS - FIX



Gerhard Magnus wrote:
On Sat, 2008-12-13 at 11:19 -0500, Bill Davidsen wrote:
Gerhard Magnus wrote:
On Fri, 2008-12-12 at 19:39 -0500, Bill Davidsen wrote:
Michael Cronenworth wrote:
-------- Original Message --------
Subject: Re: FC9 - recent upgrade breaks NFS
From: Bill Davidsen <davidsen tmr com>
To: fedora-list redhat com
Date: 12/12/2008 01:20 PM

I try not to be a whiner, but this is about the forth time in a few months that someone has released a package without ever testing it on a system with SElinux enabled. Some of those may be multiple reports, but at least three required policy changes.

You'll be happy to know that I've joined QA and I run systems with SELinux off and enforcing. There's at least one tester now that runs with SELinux. ;)

Yes, I use NFS (between SCO Unix, too) and use the machines daily. Hopefully I'll stop a lot of these bugs from hitting stable.

Thank you! And if it will be useful I can offer to install thing from updates-testing on an FC10 VM, which seem to find many if not all issues.

FIX!!

I installed selinix-policy-3.3.1-115.fc9.noarch.rpm (and targeted) and rpcbind started without issues.

As a workaround, I've (temporarily) put selinux in permissive mode but
installing selinux-policy-3.3.1-115.fc9.noarch.rpm seems safer. Wheres
did you find it? (Google is no help.) What do you mean by "and
targeted"?

yum --enablerepo=updates-testing-newkey upgrade selinux-*

That will install
  selinux-policy-3.3.1-115.fc9.noarch.rpm
  selinux-policy-targeted-3.3.1-115.fc9.noarch.rpm
and possibly, if you have it installed,
  selinux-policy-devel-3.3.1-115.fc9.noarch.rpm

Now your system works again for NFS.

This works fine for me except on the box running the 64 bit FC9. Then I
get:

Looks like the x86-64 repos are either messaged up (I see you have the out of date repomod.xml issue I see of x86-32bit), but it looks like you have both livna and rpmfusions stuff enabled by default, so you may have a total mishmash of conflicting packages from various places.

Can't help with that issue at all, works for x86 using Fedora repos.

[88] /home/magnusg $ yum --enablerepo=updates-testing-newkey upgrade
selinux-*
Loaded plugins: refresh-packagekit
livna                                                    | 2.1 kB  00:00
fedora                                                   | 2.4 kB  00:00
rpmfusion-free-updates                                   | 2.7 kB  00:00
rpmfusion-nonfree-updates                                | 2.7 kB  00:00
rpmfusion-free                                           |  951 B  00:00
updates-newkey                                           | 2.3 kB  00:00
Not using downloaded repomd.xml because it is older than what we have:
  Current   : Wed Dec 10 22:27:31 2008
  Downloaded: Tue Dec  2 16:12:33 2008
updates-testing-newkey                                   | 2.3 kB  00:00
rpmfusion-nonfree                                        |  951 B  00:00
updates                                                  | 2.6 kB  00:00
Setting up Upgrade Process
No Packages marked for Update

and still get error messages when starting NFS while booting:

NFS statd                    FAILED
mounting NFS filesystems: mount.nfs internal error
mount.nfs internal error     FAILED



--
Bill Davidsen <davidsen tmr com>
  "We have more to fear from the bungling of the incompetent than from
the machinations of the wicked."  - from Slashdot


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]