[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: mjpegtools?



Ed Greshko wrote:
> Gene Heskett wrote:
>   
>> I'd think so, but it cannot seem to accept that I have at least two complete. 
>> from the src trees of libquicktime.so.0 installed:
>>
>> [root coyote rpms]# rpm -Uvh mjpegtools-1.9.0-17_rc3.fc8.i386.rpm
>> warning: mjpegtools-1.9.0-17_rc3.fc8.i386.rpm: Header V4 DSA signature: NOKEY, 
>> key ID 66534c2b
>> error: Failed dependencies:
>>         libquicktime.so.0 is needed by mjpegtools-1.9.0-17_rc3.fc8.i386
>> [root coyote rpms]# locate libquicktime.so
>> /opt/gmerlin/lib/libquicktime.so
>> /opt/gmerlin/lib/libquicktime.so.0
>> /opt/gmerlin/lib/libquicktime.so.0.0.0
>> /opt/gmerlin-dependencies-20080715/libquicktime/libquicktime-1.0.3/src/.libs/libquicktime.so
>> /opt/gmerlin-dependencies-20080715/libquicktime/libquicktime-1.0.3/src/.libs/libquicktime.so.0
>> /opt/gmerlin-dependencies-20080715/libquicktime/libquicktime-1.0.3/src/.libs/libquicktime.so.0.0.0
>> /usr/local/lib/libquicktime.so
>> /usr/local/lib/libquicktime.so.0
>> /usr/local/lib/libquicktime.so.0.0.0
>> /usr/src/libquicktime-1.1.0/src/.libs/libquicktime.so
>> /usr/src/libquicktime-1.1.0/src/.libs/libquicktime.so.0
>> /usr/src/libquicktime-1.1.0/src/.libs/libquicktime.so.0.0.0
>> [root coyote rpms]# 
>> ln -s /usr/local/lib/libquicktime.so.0.0.0 /usr/lib/libquicktime.so.0.0.0
>> [root coyote rpms]# 
>> ln -s /usr/local/lib/libquicktime.so.0 /usr/lib/libquicktime.so.0
>> [root coyote rpms]# 
>> ln -s /usr/local/lib/libquicktime.so /usr/lib/libquicktime.so
>> [root coyote rpms]# rpm -Uvh mjpegtools-1.9.0-17_rc3.fc8.i386.rpm
>> warning: mjpegtools-1.9.0-17_rc3.fc8.i386.rpm: Header V4 DSA signature: NOKEY, 
>> key ID 66534c2b
>> error: Failed dependencies:
>>         libquicktime.so.0 is needed by mjpegtools-1.9.0-17_rc3.fc8.i386
>> [root coyote rpms]# locate libquicktime.pc
>> /opt/gmerlin/lib/pkgconfig/libquicktime.pc
>> /opt/gmerlin-dependencies-20080715/libquicktime/libquicktime-1.0.3/libquicktime.pc
>> /opt/gmerlin-dependencies-20080715/libquicktime/libquicktime-1.0.3/libquicktime.pc.in
>> /usr/local/lib/pkgconfig/libquicktime.pc
>> /usr/src/libquicktime-1.1.0/libquicktime.pc
>> /usr/src/libquicktime-1.1.0/libquicktime.pc.in
>> [root coyote rpms]# 
>> ln -s /usr/local/lib/pkgconfig/libquicktime.pc /usr/lib/pkgconfig/libquicktime.pc
>> [root coyote rpms]# rpm -Uvh mjpegtools-1.9.0-17_rc3.fc8.i386.rpm
>> warning: mjpegtools-1.9.0-17_rc3.fc8.i386.rpm: Header V4 DSA signature: NOKEY, 
>> key ID 66534c2b
>> error: Failed dependencies:
>>         libquicktime.so.0 is needed by mjpegtools-1.9.0-17_rc3.fc8.i386
>>
>> So how do I convince it, or should I just --force --nodeps it?
>>
>> Thanks Ed.
>>   
>>   
>>     
> Is /usr/local/lib in your /etc/ld.so.conf?
>
> Have you run ldconfig after your changes?
>
> When the rpm can find a dependency I've not found --force --nodeps to be
> very helpful.
>
>   
Of course my fingers meant "can't find a dependency"...  :-)

-- 
Every country has the government it deserves. -- Joseph De Maistre
Mei-Mei Greshko greshko com

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]