[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F10, VMware Server 2.0, and selinux



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Christopher A. Williams wrote:
> On Sun, 2008-12-14 at 21:27 -0500, Claude Jones wrote:
>> On Sunday 14 December 2008 18:21:44 Christopher A. Williams wrote:
>>> As to how long this has gone on, it has since F8 and VMware Server
>>> 1.0.x. The only known work-around I am aware of is to disable selinux,
>>> after which it runs impressively well. It compiles and runs on F9 and
>>> F10 out of the box with no patches needed.
>> Sorry, Christopher, but I am not posting these replies because I'm a VMWare 
>> booster. As I stated, my solution may not work for all, but, you are simply 
>> misstating things, or not speaking clearly. 
> 
> I think you may have misunderstood my point here. As the OP on this
> thread, I asked a question and someone (not you) decided to use that as
> a platform to trash VMware. I thought that was inappropriate. I see the
> problem I'm having with selinux as an inconvenience at this point, but
> would like to know how to fix it.
> 
>> To repeat, I am currently running VMWare Server version 1.0.7 build-108231; 
>> I've been running some version of VMWare server since it was first made 
>> available free, on several versions of Fedora including this machine, which is 
>> on F10; I have another machine right beside it that is running F9 and also 
>> runs VMWareServer; I do NOT disable selinux on any of my machines, ever, 
>> except for brief testing purposes; VMWare server has been running all day on 
>> this machine I'm typing on, and I have a WinXP vm running in it through which 
>> I run Outlook so I can connect to my company's Exchange 2008 mail server. 
> 
> I have been running VMware Server since it was originally GSX Server 1.0
> and a "for pay" product. I've also run VMware Workstation since the
> first public beta of version 1.0 - right up through the latest build of
> 6.5 on F10 on the laptop I'm using to write this. Unity, by the way, has
> a few minor flaws, but is otherwise very cool. I'm also a seasoned
> VMware Certified Professional (working on a VCDX), so I think I have a
> bit of qualified experience with these product lines. At least VMware
> seems to think so...
> 
> I'm happy to see you have Server 1.0 working with selinux enabled. This
> has never worked for me, and if you follow the VMware community forums
> (maybe where I should have posted this to begin with), you would see
> that I'm not alone in that. With selinux enabled and using a targeted
> policy, VMware Server will refuse to start. Placing selinux in
> permissive mode to try and catch issues produces the same result. No
> errors that I could see/find on it either. If you follow the VMware
> Community threads on this, the acknowledged work-around remains
> disabling selinux.
> 
> I occasionally try re-enabling selinux with no luck. I admit I have not
> yet tried that on the latest build of 2.0 on a recently patched F10
> system. That build only came out a couple of weeks ago and I've been
> traveling heavily - there's only so much of me to go around.
> 
>> I am merely posting this because I consider most of the information in this 
>> thread to be misleading, which could discourage others. It would be useful if 
>> you really care, to attempt to run VMWare server on your machine, post the 
>> errors you get, and get some help - to assert that it won't run because you 
>> can't get it to run, without explaining your procedures is not helpful.
> 
> Sorry you feel that way. In light of what I have written above, your "It
> works for me, so it must be something you're doing," statement doesn't
> make the info I have reported misleading. It just means your experience
> has been different (along with your opinion). I have posted this issue
> here and elsewhere before. I also have used some of my connections with
> technical people I know inside of VMware to find more on the problem.
> The answer: disable selinux. As you saw with another post, there is also
> an "anti-VMware crowd" lurking who then cries foul on VMware rather than
> advocate investigating the problem further. I don't think I have written
> anything that would confuse or discourage someone from trying or using
> VMware products. I certainly have not done so intentionally.
> 
> Since you seem to have VMware Server 1.0 working with selinux on F9 and
> F10, perhaps you should post your procedure for loading it. I might be
> able to duplicate that with a 2.0 installation. As also has been
> mentioned, you should seriously consider that VMware Server 1.x is
> reaching EOL, and you really should move to something else shortly.
> 
> Outside of the issues with selinux, I repeat that my experiences with
> 2.0 have been very positive. It's a major step forward from 1.0 as a
> server based solution.
> 
> I repeat that I would personally not recommend it as a _desktop_
> solution - but VMware Server isn't intended for that, and there are
> better desktop alternatives. I'm planning to load up another server with
> F10 and VMware Server 2.0 this weekend. I'll try this with selinux
> enabled again and report back.
> 
> Cheers,
> 
> Chris
> 
> 
> --
> ====================================
> "If you get to thinkin' you're a
> person of some influence, try
> orderin' someone else's dog around."
> 
> --Cowboy Wisdom
> 
> 
> 
If you could enable selinux in permissive mode on F10, I would love to
work thought the problems that it is causing.  I am sure it is just
getting the labeling correct.


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org

iEYEARECAAYFAklGcn0ACgkQrlYvE4MpobMqiACgzSniFjs6yq4WwLxaFVBDuKFz
6GQAn3nRNNhO3gqVSc4XjZk1cc12kZ5t
=P0jZ
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]