[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Lost audio on headphones (F9)

On Wed, Nov 26, 2008 at 9:46 AM, Paulo Cavalcanti <promac gmail com> wrote:

On Sat, Nov 22, 2008 at 9:19 PM, Andre Costa <blueser gmail com> wrote:

On Wed, Nov 19, 2008 at 10:15, Andre Costa <blueser gmail com> wrote:
Hi Tim,

On Tue, Nov 18, 2008 at 19:15, Tim <ignored_mailbox yahoo com au> wrote:
On Tue, 2008-11-18 at 15:26 -0200, Andre Costa wrote:
> my desktop computer has one of those front headphones connectors, and
> it always worked (always = since Fedora8), playing the same audio that
> goes to the front speakers. I tried it today and it doesn't work
> anymore,

Open up the volume controls and see if there's a separate volume control
just for the headphones.  You might have to wallow through the
preferences to add more controls.

Thks for the tip, but I had already done that. There's a chekcbox for headphone, which is checked. I also tried playing with every track volume level that seemed reasonable, but it did not work.

(if anyone can provide more info on any specific settings that would affect headphone sound, that'd be great...)
> my guess is that some of the recent updates might have changed
> something on audio config

You might look through /var/log/yum.log to see what's been recently
updated, and see if they're a likely cause.

I took a look, but thet fact is that I can't precise when it stopped working, so the timeframe could be long... =(

Thks anyway for your help.



Just a quick update: it's a bug with the lastest kernel. Headphone works with kernel I filed it as bug #472317:


In fact, this happened to me when I upgraded to alsa driver 1.0.18.
Going back to alsa-driver 1.01.7 solves the problem. I think your kernel
is using 1.0.18, and I doubt anyone is going to fix it.

The only option is reporting in the alsa-devel list , and maybe someone there
can do anything about it.

Well, after some work, we found out that alsa 1.0.18 (snd-hda-intel) is testing if something
is plugged to the front panel, to cut the sound on the back.
Unfortunately, some boards only detect the presence of jacks connected
to the back of the computer. Plugging, say a headphone, to the front does not change anything.
Therefore, the sound on the front of the computer is never activated.

I will test an alsa patch for my codec soon. But maybe other codecs were affected too...

Paulo Roma Cavalcanti

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]