[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: FC10 does not boot when HDD moved to another machine



Mikkel L. Ellertson wrote:
> 
> Frank Millman wrote:
> > The HDD is a standard IDE drive with a standard IDE 
> connector on the motherboard.
> > 
> I can not help with the original problem, but the problem 
> with moving the hard drive is probably a different IDE 
> controller in the second machine. The fix is to chroot 
> /mnt/sysimage and build a new initrd. (man mkinitrd) The only 
> problem being that the drive will probably not work in the 
> old machine any more. One way around this is to have 2 
> different initrd for the same kernel, and have 2 grub entries 
> - each using a different initrd.img.
> 

Thanks for the reply, Mikkel.

I tried, but unfortunately I don't know enough to figure it out :-(

I ran chroot /mnt/sysimage. I read 'man mkinitrd', but I cannot work out
what parameters to use. I tried 'mkinitrd -vf', but it just returned to the
prompt silently. I rebooted, but nothing had changed.

I cannot see anything in /boot - it seems that it is not mounted, and I
don't know how to mount it manually. /etc/fstab shows a UUID number.

It is not that important for me to get this working - I don't mind
re-installing from scratch. However, it would be nice to know how to solve
this problem for the future, in case it ever happens with live data
involved. For example, a mother board could fail, but the HDD is intact, so
you just want to move it to a new machine.

BTW, getting it to work off the old machine is not important, so a simple
re-generation of the image is sufficient.

Any assistance will be appreciated.

Frank


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]