[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: FC10 does not boot when HDD moved to another machine



Jim Cornette wrote:
> 
> Frank Millman wrote:
> > Mikkel L. Ellertson wrote:
> >> Frank Millman wrote:
> >>> The HDD is a standard IDE drive with a standard IDE
> >> connector on the motherboard.
> >> I can not help with the original problem, but the problem 
> with moving 
> >> the hard drive is probably a different IDE controller in 
> the second 
> >> machine. The fix is to chroot /mnt/sysimage and build a 
> new initrd. 
> >> (man mkinitrd) The only problem being that the drive will probably 
> >> not work in the old machine any more. One way around this 
> is to have 
> >> 2 different initrd for the same kernel, and have 2 grub entries
> >> - each using a different initrd.img.
> >>
> > 
> > Thanks for the reply, Mikkel.
> > 
> > I tried, but unfortunately I don't know enough to figure it out :-(
> > 
> > I ran chroot /mnt/sysimage. I read 'man mkinitrd', but I 
> cannot work 
> > out what parameters to use. I tried 'mkinitrd -vf', but it just 
> > returned to the prompt silently. I rebooted, but nothing 
> had changed.
> > 
> > I cannot see anything in /boot - it seems that it is not 
> mounted, and 
> > I don't know how to mount it manually. /etc/fstab shows a 
> UUID number.
> > 
> > It is not that important for me to get this working - I don't mind 
> > re-installing from scratch. However, it would be nice to 
> know how to 
> > solve this problem for the future, in case it ever happens 
> with live 
> > data involved. For example, a mother board could fail, but 
> the HDD is 
> > intact, so you just want to move it to a new machine.
> > 
> > BTW, getting it to work off the old machine is not important, so a 
> > simple re-generation of the image is sufficient.
> > 
> > Any assistance will be appreciated.
> > 
> > Frank
> > 
> 
> Something that I found to work was to use the installation 
> media and go through an upgrade, even though all you need is 
> the boot fixed.
>   Someone posted their success so I tried to fix a system 
> that I transferred from an IDE drive to a SATA drive which 
> failed to boot. Once I tried to run an upgrade the unit was 
> able to boot for the transferred SATA installation.
> 
> The upgrade process simply updated a few kernel and grub 
> items and passed on other already current packages.
> 
> Since you only changed a working install to another computer, 
> it may work.
> 
> Another possibility is that you need to run the IDE in legacy 
> mode, I found this needed for both older RHL7.3 and Centos 
> early releases. If you have IDE set to native, both older 
> distributions fail to recognize drive and  you end up with a 
> kernel panic.
> 

Thanks very much for the suggestion, Jim. I felt sure it was going to work,
but unfortunately it does not.

It starts anaconda, brings up a graphical installation screen (which is a
step forward, as my original problem was that it would not even get that
far), then after accepting the language and keyboard options, I get the
following -

Warning: The partition table on device sda (ATA ST38410A 8213 MB) was
unreadable. To create new partitions it must be initialized, causing the
loss of ALL DATA on this drive. This operation will override any previous
installation choices about which drives to ignore.

As mentioned earlier, it is not a train smash if I have to do this, but I
want to use this as a learning exercise in case one day I or a client have
this problem with critical data on the hard drive.

I rebooted in rescue mode and ran 'fdisk -l', and it lists the partitions
correctly, so I don't think the HDD is corrupted.

I don't know what it means to 'run the IDE in legacy mode'. Can you give me
some pointers, please.

Any other suggestions will be appreciated.

Frank


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]