[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC10 does not boot when HDD moved to another machine



Frank Millman wrote:

Thanks very much for the suggestion, Jim. I felt sure it was going to work,
but unfortunately it does not.

It starts anaconda, brings up a graphical installation screen (which is a
step forward, as my original problem was that it would not even get that
far), then after accepting the language and keyboard options, I get the
following -

Warning: The partition table on device sda (ATA ST38410A 8213 MB) was
unreadable. To create new partitions it must be initialized, causing the
loss of ALL DATA on this drive. This operation will override any previous
installation choices about which drives to ignore.

There was a change in the way the partition table is read toward the end of the drive. Also there is an option to overcome that limitation so the table writing in a reserved information area is ignored. I ran into that problem and had swap at the end of the disk so removing the partition and then saving the data followed by creating swap again wrote the disk into the new format honoring the reserved area criteria.

The best way to find out if this is your problem is to boot into rescue mode by typing 'linux rescue' and run fdisk -l to show all detected partitions.



As mentioned earlier, it is not a train smash if I have to do this, but I
want to use this as a learning exercise in case one day I or a client have
this problem with critical data on the hard drive.

It sounds like you picked a good situation to try to detect the problem.


I rebooted in rescue mode and ran 'fdisk -l', and it lists the partitions
correctly, so I don't think the HDD is corrupted.

That information pretty much makes my suggestion above less likely to be the culprit. I believe fdisk bombed.
I agree that the disk is most likely in good condition.


I don't know what it means to 'run the IDE in legacy mode'. Can you give me
some pointers, please.

I have a CPU board where it allows several choices for the controller operation mode. With native mode it is not even detected with Centos.

With RHL 7.3 the disk boots but ends up with a kernel panic in native mode. If I choose legacy mode the system boots all the way without a kernel panic. The system needed to have the CPU board, a single board computer replaced. The old board is discontinued so I needed to replace the 370 socket board with a board with the Pentium M. A big change but 370 sockets are becoming rare. After changing the native mode to legacy mode in CMOS the system booted and kudzu removed all of the old hardware and asked to configure the newly detected hardware. It works now in CLI mode but Complained that it configured X but the card is not in the database.

Back on topic. The setting is in CMOS setup selections. It may be called different from BOIS type to another.


Any other suggestions will be appreciated.

Frank



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]