[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: f10: kpackagekit; authentication failed



g wrote:
> when i select 'update' again, i get a notice of 'authentication failed'.

Are you trying to use it as root? PolicyKit chokes on that:
https://bugzilla.redhat.com/show_bug.cgi?id=447266
and as PolicyKit is what handles authentication in PackageKit (and thus also
KPackageKit), this also affects KPackageKit.

Try using KPackageKit as a non-root user. I could also provide you with a
patched PolicyKit which works as root if you absolutely need to run
KPackageKit as root.

        Kevin Kofler


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]