[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC10 does not boot when HDD moved to another machine





On Sun, Dec 21, 2008 at 10:34 AM, Paulo Cavalcanti <promac gmail com> wrote:


On Sun, Dec 21, 2008 at 8:36 AM, Frank Millman <frank chagford com> wrote:
Mikkel L. Ellertson wrote:
>
> Frank Millman wrote:
> >
> > Still no luck, I am afraid. This is what I have done.
> >
> > #chroot /mnt/sysimage.
> >
> > 'uname -r' shows 2.6.27.5-117.fc10.i586
> >
> > I ran 'mkinitrd -v /boot/test.img 2.6.27.5-117.fc10.i586'.
> I put the
> > -v in to see what was happening, but it just returns to the
> prompt silently.
> >
> I think that should be:
>
> mkinitrd -v /boot/test.img 2.6.27.5-117.fc10
>
> (no .586)
>
> > #ls /boot shows nothing - I don't think it is mounted.
> >
> easy fix - "mount /boot" after running chroot.
>
> I am surprised that you did not get an error when it could
> not find the kernel.
>
> No modules available for kernel "2.6.27.5-117.fc10.i586"
>

Thanks for your patience, Mikkel. I think I am getting closer.

I tried the suggestion of running 'yum update kernel' while in rescue mode
on the second machine. It seemed to work, but it still would not boot.

I put the drive back in the original machine, and it booted ok. The problem
with X freezing seems to have gone away, so I will use it in this machine as
originally intended. However, I would still like to complete the exercise of
getting it to boot in the other machine. (Aarhg, I spoke to soon! I just
tried it again and it has frozen. However, that is a topic for another
thread ...)

I ran 'yum update', which updated 53 packages. As mentioned I had previously
run 'yum update kernel'. The kernel now seems to be 2.6.27.7-134.fc10.i686.
However, uname -r still shows 2.6.27.5-117.fc10.i586. What is the official
way of finding out which kernel is running?

I ran mkinitrd on the original machine, just to see if it would work. If I
type 'mkinitrd -v /boot/test.img 2.6.27.7-134.fc10' (without the .i686), I
get the message 'No  modules available ...' If I include the '.i686', it
works, and creates /boot/test.img.

I don't know how to tell it to use the new image. Is there a way to change
boot options without booting off the intstallation dvd and selecting 'rescue
mode'? I did boot in rescue mode, and tried 'initrd=test.img' and
'initrd=/boot/test.img', but in both cases it said it could not find
test.img.

You mentioned modifying grub.conf, but I do not have a grub directory in
/boot at all. There is an an entry in /etc for grub.conf, but it is a link
to /boot/grub/grub.conf, so it cannot find it.

I then moved the HDD back to the second machine and booted in rescue mode.
This time 'ls /boot' did show the contents correctly - the previous problem
where it did not seem to be mounted has gone away. I ran mkinitrd and it
worked, but I still don't know how to tell it to use the new image. I tried
saving '/boot/initrd-2.6.27.7-134.fc10.i686.img', and then copying
'test.img' over it, but when I tried booting normally I got the original
error message -

Volume group "VolGroup00" not found
Unable to access resume device (/dev/VolGroup00/LogVol01)
mount: error mounting /dev/root on /sysroot as ext3: No such file or
directory

I suspect that I am closer, and my problem now is that I don't know how to
tell it to use the new image. Hopefully someone can give me a nudge in the
right direction.



What does

rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE}.{ARCH}\n"|grep kernel|sort

return?

Also, what do you have in /etc/grub.conf?



Sorry. It is

rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n" | grep kernel | sort


--
Paulo Roma Cavalcanti
LCG - UFRJ

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]