[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC10 does not boot when HDD moved to another machine



Frank Millman wrote:
> 
> I tried the suggestion of running 'yum update kernel' while in rescue mode
> on the second machine. It seemed to work, but it still would not boot.
> 
This will only work if you booted in the rescue mode on the new
machine, and ran chroot /mnt/sysimage. (Mount /boot after that if it
didn't get mounted.)
> 
> I ran 'yum update', which updated 53 packages. As mentioned I had previously
> run 'yum update kernel'. The kernel now seems to be 2.6.27.7-134.fc10.i686.
> However, uname -r still shows 2.6.27.5-117.fc10.i586. What is the official
> way of finding out which kernel is running?
> 
Did you reboot after installing the new kernel? The new kernel
should be used when you reboot. If it is not show as the default
kernel when booting, hit the down arrow while Grub is counting down,
and select the kernel from the menu.

> I ran mkinitrd on the original machine, just to see if it would work. If I
> type 'mkinitrd -v /boot/test.img 2.6.27.7-134.fc10' (without the .i686), I
> get the message 'No  modules available ...' If I include the '.i686', it
> works, and creates /boot/test.img.
> 
OK - I guessed they changed things in F10.

> I don't know how to tell it to use the new image. Is there a way to change
> boot options without booting off the intstallation dvd and selecting 'rescue
> mode'? I did boot in rescue mode, and tried 'initrd=test.img' and
> 'initrd=/boot/test.img', but in both cases it said it could not find
> test.img.
> 
You can edit the kernel line in Grub before it boots the kernel. If
we have to go that route, we can cover it. (My brain is froze - I
was out shoveling/snow blowing snow...)

> You mentioned modifying grub.conf, but I do not have a grub directory in
> /boot at all. There is an an entry in /etc for grub.conf, but it is a link
> to /boot/grub/grub.conf, so it cannot find it.
> 
It sounds like you are not getting all partitions mounted when
booting in the rescue mode. After doing the chroot /mnt/sysimage,
run mount /boot and it should show up.

> I then moved the HDD back to the second machine and booted in rescue mode.
> This time 'ls /boot' did show the contents correctly - the previous problem
> where it did not seem to be mounted has gone away. I ran mkinitrd and it
> worked, but I still don't know how to tell it to use the new image. I tried
> saving '/boot/initrd-2.6.27.7-134.fc10.i686.img', and then copying
> 'test.img' over it, but when I tried booting normally I got the original
> error message -
> 
You HAVE TO build the new initrd image on the new machine. If you
build it on the old machine, it will have the drivers for the old
machine. This not what you want. (The image is the same as the one
you are trying to boot off of now, and is not working.)

Mikkel
-- 

  Do not meddle in the affairs of dragons,
for thou art crunchy and taste good with Ketchup!

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]