[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

F9: Sendmail Issues...




I am having a bit of trouble getting sendmail to work
properly.  Strangely, I encountered something that I
never saw before (in messages log file when (re)starting
sendmail), but found resolution for, was this:

in Messages log file:
STARTTLS: CRLFile missing

The solution is:
1) cd /etc/pki/tls/certs
2) wget http://www.cacert.org/revoke.crl
3) Edit /etc/mail/sendmail.mc and add line:
  define(`confCRL', `/usr/share/ssl/certs/revoke.crl')
4) chcon -u system_u /etc/pki/tls/certs/revoke.crl
5) service sendmail restart
... and the message in messages no longer appears.

With that out of the way, I am still unable to figure
out why I am not able to get Thunderbird (IMAP) to
connect to my local system, sendmail port 25.

But I do notice, that I can telnet localhost 25, and the sendmail
prompt appears, I can, on other machines local to my network
`telnet <host-under-test> 25' and sendmail prompts as well.

I am still trying to figure this out to no resolution at this point,
and do not know what to do...

Another issue.  I get the following, also appearing in Messages log file:

Dec 21 14:08:01 bronze sendmail[10866]: mBLM81Fn010866: --- 250 2.0.0 mBLM81Fn010866 Message accepted for delivery Dec 21 14:08:01 bronze sendmail[10865]: mBLM81eu010865: to=apache, ctladdr=apache (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30449, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (mBLM81Fn010866 Message accepted for delivery) Dec 21 14:08:01 bronze sendmail[10868]: mBLM81Fn010866: alias <apache localhost localdomain> => root
Dec 21 14:08:01 bronze sendmail[10868]: mBLM81Fn010866: alias root => dant
Dec 21 14:08:01 bronze sendmail[10866]: STARTTLS=read, info: fds=6/4, err=2
Dec 21 14:08:01 bronze sendmail[10866]: mBLM81Fo010866: <-- QUIT
Dec 21 14:08:01 bronze sendmail[10866]: mBLM81Fo010866: --- 221 2.0.0 localhost.localdomain closing connection Dec 21 14:08:01 bronze sendmail[10866]: STARTTLS=server, SSL_shutdown not done Dec 21 14:08:01 bronze sendmail[10866]: mBLM81Fo010866: Milter (clamav-milter): quit filter Dec 21 14:08:20 bronze sendmail[10868]: mBLM81Fn010866: to=dant, ctladdr=<apache localhost localdomain> (48/48), delay=00:00:19, xdelay=00:00:19, mailer=local, pri=31141, dsn=2.0.0, stat=Sent Dec 21 14:08:20 bronze sendmail[10868]: mBLM81Fn010866: done; delay=00:00:19, ntries=1

Clearly, apache is sending a local message of a problem,
but what I do not understand are these lines:

1) Dec 21 14:08:01 bronze sendmail[10866]: STARTTLS=read, info: fds=6/4, err=2 2) Dec 21 14:08:01 bronze sendmail[10866]: STARTTLS=server, SSL_shutdown not done

Does anyone have any suggestions what I can do for further
investigation as to what is going on, if there is a problem,
or if these issues can be fixed?

Thanks!
Dan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]