[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: FC10 does not boot when HDD moved to another machine



Mikkel L. Ellertson wrote:
> 
> Frank Millman wrote:
> > 
[...]
> > I ran mkinitrd on the original machine, just to see if it 
> would work. 
[...]
> 
> > I don't know how to tell it to use the new image. Is there a way to 
> > change boot options without booting off the installation dvd and 
> > selecting 'rescue mode'? I did boot in rescue mode, and tried 
> > 'initrd=test.img' and 'initrd=/boot/test.img', but in both cases it 
> > said it could not find test.img.
> > 
> You can edit the kernel line in Grub before it boots the 
> kernel. If we have to go that route, we can cover it. (My 
> brain is froze - I was out shoveling/snow blowing snow...)
> 

As I mentioned before, there is no grub directory in /boot, so there is no
grub menu on bootup. I don't know why. All I can do is press <esc> once
booting has started, and it changes from a progress bar to the old text
display, but there does not seem to be any place where I can add or change
boot options.

> You HAVE TO build the new initrd image on the new machine. If 
> you build it on the old machine, it will have the drivers for 
> the old machine. This not what you want. (The image is the 
> same as the one you are trying to boot off of now, and is not 
> working.)
> 

I did do this, and it seemed to build ok. However, I don't know how to tell
it to use the newly created image.

I did a search for '*grub*' on my system. It found a few files. The
following could be relevant -

1. /etc/sysconfig/grub
    boot=/dev/sda
    forcelba=0

2. /sbin/grub-install
    I ran it, but it asked for an install_device. I prefer not to guess, so
I did not try any further.


For the record, 'ls /boot' looks like this -

config-2.6.27.7-134.fc10.i686
initrd-2.6.27.7-134.fc10.i686.img
System.map-2.6.27.7-134.fc10.i686
vmlinuz-2.6.27.7-134.fc10.i686

If I type 'umount /boot', it says '/boot: not mounted'. Is that expected? As
mentioned in my reply to Paulo, /etc/fstab has changed. It used to contain
an entry for /boot, but now it does not. I am not sure when it changed, but
I think it was when I selected Install/Upgrade on the second machine. I got
a warning message and did not proceed, but a couple of things seem to have
changed after that.

It is quite possible that my messing around has left things in a state which
makes it difficult to diagnose problems. If you would like me to re-install
from scratch on the first machine and start the whole process again, I will
try that. I think it is worth persevering with this exercise to prove a
point. Hopefully others may find it of benefit as well.

Any more suggestions will be appreciated.

Thanks

Frank


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]