[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: PackageKit has eaten my system (again!)




Message: 9 Date: Sun, 21 Dec 2008 17:03:48 -0700 From: Kevin Fenzi <kevin scrye com> Subject: Re: PackageKit has eaten my system (again!) To: fedora-list redhat com Message-ID: <20081221170348 42475e34 ohm scrye com> Content-Type: text/plain; charset="us-ascii" On Sun, 21 Dec 2008 22:13:46 +0000 Anne Wilson <annew kde org> wrote:
> On Sunday 21 December 2008 22:00:16 DB wrote:
> >
> > [Dave localhost ~]$ rpm -qi pygpgme
> > package pygpgme is not installed
> > [Dave localhost ~]$ rpm -qi python-iniparse
> > package python-iniparse is not installed
> > [Dave localhost ~]$
> >
> > Is there a way to tell rpm to go off and search a specific repo?

no. Rpm only acts on specific packages.
> If they are not installed 'yum install packagename' should pull them
> in - and you can list both packages in one command.

Except that he is trying to install yum. ;)
> > I
> > tried rpm --whatprovides yum but that evidently is not acceptable!
> > It's not apparent from the help file, but I think the command is 'rpm
> -q whatprovides ....' but I don't think that would have helped in
> this situation. I'd try
> > yum install pygpgme python-iniparse yum

No yum installed there for him. ;) Dave: Try the following:
rpm -ivh
http://mirrors.tummy.com/pub/fedora.redhat.com/fedora/linux/updates/9/i386.newkey//yum-3.2.20-5.fc9.noarch.rpm
http://mirrors.tummy.com/pub/fedora.redhat.com/fedora/linux/releases/9/Everything/i386/os//Packages/pygpgme-0.1-8.fc9.i386.rpm http://mirrors.tummy.com/pub/fedora.redhat.com/fedora/linux/releases/9/Everything/i386/os//Packages/python-iniparse-0.2.3-3.fc9.noarch.rpm

All on one big long line. ;) Not sure if there are further deps, but hopefully that will get yum installed for you.
kevin

Thanks Kevin......

In the order you listed the rpms, the yum failed needing pygpgme.... So I tried installing them t'other way around:

[root localhost ~]# rpm -ivh http://mirrors.tummy.com/pub/fedora.redhat.com/fedora/linux/releases/9/Everything/i386/os//Packages/pygpgme-0.1-8.fc9.i386.rpm http://mirrors.tummy.com/pub/fedora.redhat.com/fedora/linux/releases/9/Everything/i386/os//Packages/python-iniparse-0.2.3-3.fc9.noarch.rpm http://mirrors.tummy.com/pub/fedora.redhat.com/fedora/linux/updates/9/i386.newkey//yum-3.2.20-5.fc9.noarch.rpm Retrieving http://mirrors.tummy.com/pub/fedora.redhat.com/fedora/linux/releases/9/Everything/i386/os//Packages/pygpgme-0.1-8.fc9.i386.rpm Retrieving http://mirrors.tummy.com/pub/fedora.redhat.com/fedora/linux/releases/9/Everything/i386/os//Packages/python-iniparse-0.2.3-3.fc9.noarch.rpm Retrieving http://mirrors.tummy.com/pub/fedora.redhat.com/fedora/linux/updates/9/i386.newkey//yum-3.2.20-5.fc9.noarch.rpm
error: Failed dependencies:
   libgpgme.so.11 is needed by pygpgme-0.1-8.fc9.i386
   libgpgme.so.11(GPGME_1.0) is needed by pygpgme-0.1-8.fc9.i386
[root localhost ~]#

Any idea where the so.11 files might be?? (or how with my limited knowledge of the remnants of my system, I should go about finding the deps??))

Thanks again

Dave


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]