[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: static IP under F10



Alain Roger wrote:
Hi,

i have setup a static IP for my F10 computer (which will be use later as DB server for test development).
therefore i modify the following 3 files:
/etc/sysconfig/networking/devices/ifcfg-eth0
/etc/sysconfig/networking/profiles/default/ifcfg-eth0
/etc/sysconfig/network-scripts/ifcfg-eth0

i setup my mask to 255.255.255.0 as usual and after i reboot F10.
after login as user, F10 as setup eth0 inactive. when i press the button activate, eth0 is activated but the mask turns to my default gateway address... and internet does not work.

where is the problem ?
i'm sure that this IP address is free and works if i use it on windows OS.
thx a lot.

--
Alain
-----------------------------------------------------------
Windows XP x64 SP2 / Fedora 10 KDE 4.2
PostgreSQL 8.3.5 / MS SQL server 2005
Apache 2.2.10
PHP 5.2.6
C# 2005-2008
You only need to change /etc/sysconfig/network-scripts/ifcfg-eth0 .
Check into /etc/resolv.conf for the correct DNS. This is where your DNS is setup to get you on the Internet. Are you using a gateway router or direct to the DSL box ? Here is a working /etc/sysconfig/network-scripts/ifcfg-eth0 to compare by; After all changes are made , restart your computer, all damons will also be restarted

DEVICE=eth0
ONBOOT=yes
TYPE=Ethernet
BOOTPROTO=static
IPADDR=192.168.1.254       # your static IP here
NETMASK=255.255.255.0
NETWORK=
BROADCAST=192.168.1.255
GATEWAY=192.168.1.1        # which is a router
HWADDR=00:16:EC:69:37:55   # put your own MAC adress here
DNS1=
IPV6INIT=no
USERCTL=no
PEERDNS=yes
 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]