[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: libdrm-2.4.3 needs pthreads-stubs, not available for fedora, why?



On Friday 26 December 2008, Petrus de Calguarium wrote:
>Gene Heskett wrote:
>> libxcb-devel (and libxcb) are ancient and do not  contain the required
>> headers.
>
>I don't know a thing about pthreads-stubs, but I had a dependency problem
> many months ago that required pthreads. It turns out that in fedora, it is
> called pth. Perhaps this helps?

Not sure, pth and pth-devel have been installed since forever.  Are you saying 
I need to hack the ./configure script & subsequent Makefiles?, or what?

Here is the error:
checking for PTHREADSTUBS... configure: error: Package requirements 
(pthread-stubs) were not met:

No package 'pthread-stubs' found
-----------
and there are no *stubs in the pth/pth-devel rpms.  Ack to google, the headers 
are supposedly in the libxcb tarball, but the libxcb rpm available for even 
F11, is many, many versions too old and doesn't contain the headers needed.

Thanks, yell if any more ideas surface.

-- 
Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
The truth is what is; what should be is a dirty lie.
		-- Lenny Bruce


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]