[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Logwatch report on another machine?



Dave Burns wrote:

>> How can I get the logwatch report on one machine (helen.gayleard.com)
>> sent to another machine (alfred.gayleard.com) on the same LAN?
>>
>> I tried editing /etc/aliases on the first machine,
>> changing the last line to
>>        root:           tim alfred gayleard com
>> (and running newaliases) but this did not do the trick.
> 
> That should be good enough, *if* sendmail is working on that machine
> and that address doesn't bounce. If you do
> 
> echo 'testing the client'|mutt -s 'testing client' 
> tim alfred gayleard com
> 
> do you ever get the email?

First of all, thanks for your response.
I tried the above command, but the mail did not get through.

Looking at /var/log/maillog on helen I see the lines
-------------------------------
Jun  4 02:27:56 helen sendmail[10504]: m541RtCq010504:
to=tim alfred gayleard com, ctladdr=tim (500/500), delay=00:00:01,
xdelay=00:00:01, mailer=relay, pri=30326, relay=[127.0.0.1] [127.0.0.1],
dsn=2.0.0, stat=Sent (m541Rtds010505 Message accepted for delivery)
Jun  4 02:27:56 helen sendmail[10507]: m541Rtds010505:
to=<tim alfred gayleard com>, ctladdr=<tim helen gayleard com> (500/500),
delay=00:00:01, xdelay=00:00:00, mailer=relay, pri=120482,
relay=smtp.eircom.net [159.134.198.135], dsn=5.6.0, stat=Dataformat error
Jun  4 02:27:56 helen sendmail[10507]: m541Rtds010505: m541Ruds010507: DSN:
Data format error
-------------------------------

I suspect this means the email was sent to my ISP, eircom.net ,
who rejected the email on the grounds the address was unknown or wrong.

> I am also assuming you haven't tweaked the default config of logwatch.
> 
> Speaking of which, you could try changing the "mailto" field in
> /etc/logwatch/conf/logwatch.conf.

This file was empty (except for a comment line) on my Fedora-9 system.
But I've added
-------------------------------
MailTo = tim alfred gayleard com
MailFrom = Logwatch
-------------------------------
and will see if this does the trick.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]