[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

F9 Installation Challenge

As mentioned in a couple of previous mails to this list, trying to
upgrade my laptop[1] from F8 to F9 has gone horribly wrong. I'd really
appreciate any help to fix this.

I basically have two problems.

1/ I can't use any of the Fedora boot media. When I boot with the
installation DVD I get to the "press enter to install or upgrade
Fedora" screen, but the keyboard is disabled so I can't press enter.
I've also tried with the Live CD and the rescue disk, but neither of
those work either. I've also created a boot USB key, but the BIOS on
this system doesn't support booting like that. This is a problem I've
hard with Fedora installation media right back to F7. For the last few
upgrades I've used "yum upgrade".

2/ I then tried to use preupgrade. It all seemed to go ok until the
end, when I got an error about a missing kernel. On rebooting, grub
only shows me Windows and the preupgrade options (no standard Linux).
The preupgrade option doesn't work (errors about missing files).
Booting into Windows and using Explore2FS shows that a lot (if not
all) of the kernel rpm seems to be missing.

So that's the current situation. Most of F9 seems to be installed, but
I can't boot it. I think it would work if I could boot the rescue disk
and force an installation of the kernel rpm. But I can't boot the
rescue disk.

I've run out of ideas. I really want Fedora on this laptop, but I
can't think of a way to do it. Any advice that anyone can give me
would be much appreciated.

If anyone can give me information that allows me to get F9 installed
on this laptop then I've got $100 that I'd like to donate to your
favourite open source project or charity.



[1] A Philips Freevents X51 - which is a rebadged Twinhead 12D.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]