[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Changes in kernel mess up Cisco VPN build



--- On Tue, 6/10/08, Antonio Olivares <olivares14031 yahoo com> wrote:

> From: Antonio Olivares <olivares14031 yahoo com>
> Subject: Re: Changes in kernel mess up Cisco VPN build
> To: "For users of Fedora" <fedora-list redhat com>
> Date: Tuesday, June 10, 2008, 10:16 PM
> --- On Tue, 6/10/08, Richard England
> <rlengland verizon net> wrote:
> 
> > From: Richard England <rlengland verizon net>
> > Subject: Changes in kernel mess up Cisco VPN build
> > To: "For users of Fedora"
> <fedora-list redhat com>
> > Date: Tuesday, June 10, 2008, 9:50 PM
> > Is there anyone here that builds kernel modules that
> might
> > provide some 
> > insight into what might have changed in the kernel
> between 
> > 2.6.25.3-18.fc9.i686  and  2.6.25.4-30.fc9.i686 to
> cause an
> > invalid 
> > module format to be built?  These are, I believe the
> next
> > to last and 
> > last kernel updates, respectively.
> > 
> > The builds under both kernels appear to run correctly
> (no
> > error 
> > messages) but when you try install the module it
> errors:
> > 
> > 
> > [root wimsey vpnclient]# /etc/init.d/vpnclient_init
> start
> > Starting /opt/cisco-vpnclient/bin/vpnclient: insmod:
> error
> > inserting 
> >
> '/lib/modules/2.6.25.4-30.fc9.i686/CiscoVPN/cisco_ipsec.ko':
> > -1 Invalid 
> > module format
> > Failed (insmod)
> >
> After building the packages run dmesg to see how they are
> loaded. 
> $ su -
> password:
> # modprobe cisco_ipsec
> 
> what does it give you?
> 
> then run dmesg on the same terminal or another tabbed one
> $ dmesg
> 
> should output something back about compatibility.   
> > 
> > 
> > This is the 
> > vpnclient-linux-x86_64-4.8.01.0640-k9_f8.tar.gz build
> from 
> > Cisco (obtainable from  
> >
> ftp://ftp.tu-graz.ac.at/vc-graz/vpn/vpnclient-linux-x86_64-4.8.01.0640-k9.tar.gz
> > as modified by the patch from
> >
> http://projects.tuxx-home.at/ciscovpn/patches/vpnclient-linux-2.6.24-final.diff
> >
> The patch is for 2.6.24 kernels right?, there were some
> changes in the newer 2.6.25 kernels, the fastcall,
> FASTCALL() procedures were removed.  I had a problem with
> building drivers for a modem, I have an external modem, but
> could not connect with Fedora using it, only with SLAX.  
> 
> Anyhow the Makefile had 
> EXTRA_CFLAGS += ????
> and changing it to 
> EXTRA_CPPFLAGS += ????
> 
> fixed it for me.  Give it a try and report back.  
> 
> -EXTRA_CFLAGS += -DKMARTIAN_STAMP=20061202
> +EXTRA_CPPFLAGS += -DKMARTIAN_STAMP=20061202
> 
> HTH,
> 
> Antonio 
> > 
> > The tar file contains an install script that uses make
> but,
> > while I can 
> > read the make file, I'm a relative newby when  it
> comes
> > to modules so 
> > any insight will be helpful. 
> > 
> > Thanks,
> > 
> > ~~Richard
> > 
> > -- 

BTW, someone has a similar problem to yours

http://www.fedoraforum.org/forum/showthread.php?t=191355

Regards,

Antonio 


      


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]