[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

ssmtp, normal user can't access it



Hi,
I have a smaill linux box (MyBookWorld NAS) with this system

Linux MyBookWorld 2.6.17.14 #1 PREEMPT Fri Jan 18 10:40:25 GMT 2008 armv5tejl GNU/Linux

I use getmail to fetch mails, mutt as mailer and ssmtp as MTA. getmail and mutt work ok. there is a bit problem with ssmtp

As a normal user, I call ssmtp via a line in the mutt configure file muttrc as this

set sendmail="/sbin/ssmtp -t -i"

When to send mail via mutt, it always aborted and show this error
ssmtp: can't resolve symbol '__guard'

This user has sudo right.
if I set muttrc as this

set sendmail="sudo /sbin/ssmtp -t -i"

send mail via mutt is working.

I tried command line ssmtp as a normal user or as sudo user, it behavours the same. Not working and the same error message for normal user, but worked for sudo user.

please as this is very light system, sendmail is not installed here.

could someone point me to fix?

Y



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]