[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: MythTV and repo conflicts...



On Fri, Jun 13, 2008 at 11:14 AM, Bill Crawford
<billcrawford1970 gmail com> wrote:
> 2008/6/13 Daniel B. Thurman <dant cdkkt com>:
>>
>> My current repo list is the default fedora repos PLUS livna.
>>
>> When I tried to install MythTV, I get this error:
>> Error: Missing Dependency: libmp4ff.so.0 is needed by package mythmusic
>>
>> Some say that I need to disable livna, install atrpms repos, enable it, then
>> yum remove faad2
>>
>> But if so, it would remove:
> ...
>> Any advice?
>
> Where is the mythmusic package from?
>
> If possible, you want to *replace* the faad2 rpm (rather than remove
> it) with one that has the missing library, or find the package that
> provides it (I'm guessing this will be from atrpms). This means making
> sure it has the same versions of the libs you need for the other
> packages on your system, obviously ...
>

Don't keep both atrpms and livna enabled at the same time. I once had
a runaway situation in FC6 where one of the repos some how installed
and additional repo and it got to the point I couldn't update
anything. Since then I only keep one 3rd party repo enabled.

That doesn't mean I don't have the others installed, however, as soon
as I install them I go into the .repo file and change enabled from 1
to 0. I can still use it for specific packages I want by using
--enablerepo= when executing yum.

Richard


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]