[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Where is /usr/include/gnu/stubs.h?





--- On Fri, 6/13/08, Ralf Corsepius <rc040203 freenet de> wrote:

> From: Ralf Corsepius <rc040203 freenet de>
> Subject: Re: Where is /usr/include/gnu/stubs.h?
> To: olivares14031 yahoo com, "For users of Fedora" <fedora-list redhat com>
> Date: Friday, June 13, 2008, 10:08 PM
> On Fri, 2008-06-13 at 22:01 -0700, Antonio Olivares wrote:
> > Dear all,
> > 
> > In trying to create a SLMODEMD.gcc4.3, that will serve
> many users who use slmodemd + alsa component, I encounter
> the error in subject "(
> > 
> > Is there any place that this file exists?
> > Has this file been depracated?
> > 
> > [olivares localhost slmodem-2.9.11-20080417]$ cd
> modem/
> > [olivares localhost modem]$ make SUPPORT_ALSA=1
> > rebuild profile...
> > gcc -m32 -Wall -g -O -I. -DCONFIG_DEBUG_MODEM
> -DSUPPORT_ALSA=1   -o modem_main.o -c modem_main.c 
> > In file included from /usr/include/features.h:359,
> >                  from /usr/include/string.h:26,
> >                  from modem_main.c:48:
> > /usr/include/gnu/stubs.h:7:27: error: gnu/stubs-32.h:
> No such file or directory
> 
> # rpm -qf /usr/include/gnu/stubs-32.h
> glibc-devel-2.8-3.i386
> 
> Are you on x86_64? Then, you probably only have the x86_64
> version of
> glibc-devel installed and need to additionally install the
> i386 version.
> 
> Ralf

Yes I am on x86_64 bit machine.  Installing at the moment

[root localhost ~]# yum install glibc-devel
Loaded plugins: refresh-packagekit
updates                                                  | 2.3 kB     00:00    
fedora                                                   | 2.4 kB     00:00    
Setting up Install Process
Parsing package install arguments
Package glibc-devel-2.8-3.x86_64 already installed and latest version
Nothing to do
[root localhost ~]# yum list glibc-devel*
Loaded plugins: refresh-packagekit
Installed Packages
glibc-devel.x86_64                       2.8-3                  installed       
Available Packages
glibc-devel.i386                         2.8-3                  fedora          
[root localhost ~]# yum install glibc-devel.i386 
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package glibc-devel.i386 0:2.8-3 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 glibc-devel             i386       2.8-3            fedora            2.1 M

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 2.1 M
Is this ok [y/N]: y


Thank you very much for your kind help Ralf :)

Regards,

Antonio 


      


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]