[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Recent updates caused Grub installation to be damaged?



I updated this morning for the new kernel plus another 30 or so updates.

After rebooting, I got a screen that read just GRUB, then nothing.

Initially I thought that the device.map file might have been the
problem, it had an entry for fd0 in it as the first device, then hd0
as /dev/sda. I edited the file to remove the fd0 entry and tried again,
but still the same result. In the end I re-installed grub again and got
the correct stage 1.5 message before the Grub screen came up.

Has anyone else had problems of this nature on updates recently? I
suppose this could have been a glitch but I've never had a boot sector
damaged before in this way in all the time I've been using Redhat and
Fedora, it looks like there was enough left intact to try and boot with
but then grub couldn't find the files needed to continue.

-- 

Brian Morrison

   "Arguing with an engineer is like wrestling with a pig in the mud;
    after a while you realize you are muddy and the pig is enjoying it."


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]